Record locking in Vantage 6.1

Warren,

There are a lot of sources for performance issues with Vantage 6.1 but record locking is not the likely culprit. Case in point is your example of the Engineering Workbench. When opening the workbench, Progress is perfectly content to retrieve locked records as dirty reads with no performance hit. Not until a user attempts to commit a change to a locked record will the application respond with a "record in use by another user" error. As a result, you could have all of the records locked and it would not affect the workbench opening performance.

As was mentioned already, if you migrated from a prior version or, more likely, changed to a new server there could be residual registry entries on the workstation that are causing resolution delays that result in poor performance. The usual symptom of this type of problem is poor startup/login times. Another possibility is an improperly tuned production database. If the DB is running with the default settings and has accumulated some data over the years you can experience severely degraded performance. You can experience performance degradation if you have logging turned on to a large number of fields. If your scatter factor is large you may need a dump and load. You may have an enormous Bi file that needs to be truncated.

In short, there a lots of possible sources for the performance problems you are experiencing but, frankly, record locking isn't a very likely candidate. Oh yeah, you can use promon to verify the locking status and proutil with the tabanalys parameter to determine the scatter factor.

Regards,

Michael

Michael Barry
Aspacia Systems Inc
866.566.9600
312.803.0730 fax
http://www.aspacia.com/


On Sep 20, 2010, at 12:44 PM, warren klug wrote:

> I am being told by third party consultant that slowness in our current system Vantage 6.1 is due to record locking. He was on the phone with an Epicor support staff that confirmed this based more via a suspicion and not any actual data. I see that there are performance issues popping up with version 9 so a migration may not solve performance problems moving forward. Is there any way to confirm that performance issues in 6.1 could be related to record locking. An example of speed is taking 3 to 5 minutes for the Engineering Workbench to open. The last thing I want to do is to jump on board with system upgrades and data migration moving to version 9.x in hopes of increasing speed then realize that we just traded one performance headache in for a new one.
>
> Thanks,
> Warren
> Lion Brothers Company Inc.
>
> [Non-text portions of this message have been removed]
>
>



[Non-text portions of this message have been removed]
I am being told by third party consultant that slowness in our current system Vantage 6.1 is due to record locking. He was on the phone with an Epicor support staff that confirmed this based more via a suspicion and not any actual data. I see that there are performance issues popping up with version 9 so a migration may not solve performance problems moving forward.  Is there any way to confirm that performance issues in 6.1 could be related to record locking.  An example of speed is taking 3 to 5 minutes for the Engineering Workbench to open. The last thing I want to do is to jump on board with system upgrades and data migration moving to version 9.x in hopes of increasing speed then realize that we just traded one performance headache in for a new one. Â
Â
Thanks,
Warren
Lion Brothers Company Inc. Â




[Non-text portions of this message have been removed]
Warren



Have you tried running a registry cleaner (free one like Microsoft
regclean should do). Sometimes you can get orphaned entries which
reference old server names that slow down some screens.



Gary



From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
Of warren klug
Sent: 20 September 2010 20:45
To: vantage@yahoogroups.com
Subject: [Vantage] record locking in Vantage 6.1





I am being told by third party consultant that slowness in our current
system Vantage 6.1 is due to record locking. He was on the phone with
an Epicor support staff that confirmed this based more via a suspicion
and not any actual data. I see that there are performance issues
popping up with version 9 so a migration may not solve performance
problems moving forward. Is there any way to confirm that performance
issues in 6.1 could be related to record locking. An example of speed
is taking 3 to 5 minutes for the Engineering Workbench to open. The
last thing I want to do is to jump on board with system upgrades and
data migration moving to version 9.x in hopes of increasing speed then
realize that we just traded one performance headache in for a new one.


Thanks,
Warren
Lion Brothers Company Inc.

[Non-text portions of this message have been removed]





[Non-text portions of this message have been removed]