Report Data Def table delete issue

I have an RDD that I was experimenting with, and now when I try to delete a table I added, I get the following error:

Cannot delete the Report table as there are Print Routing rules using it. Delete the Print Routing rules by using the Report Style Maintenance form before attempting to delete the table.

I queried the ReportStyle and ReportStyleRule tables.

  • This RDD is used on a couple of Report styles, but none of them have any Break/Routings setup.

  • The ReportStyleRule table shows no ReportRules using this RDD.

Anyone run into this before, or know where to look next?

Follow up info.

I just copied the RDD to a new one (using Actions \ Duplicate Report), and get the same error when trying to delete a table from the new RDD - which obviously has no Report Styles using it.

EDIT: Update #2

While I could not delete the table from the copy of the RDD, I could delete the whole copied RDD.

I know this was three years ago, but did you by chance find a solution other than Recreating the RDD? I just got done recreating mine and accidentally added an additional table and am receiving the error again…

Nope. All I got from support was:

Relating to your ERP10 case: CS0000556971 I tested the Addition and Removal (deletion of Tables added to a duplicated RDD) in 10.1.400.2x versions and could not duplicate the ‘deleting’ problem you had reported encountering, so that indicates there is no bug in the software. It is possible that there is something unique about your Duplicated RDD(s) which are possibly different than a regular duplicated RDD.
Please let me know if the condition persists on your end, I can certainly give you a call to review further.

FWIW - The post was made while we were still on 10.1.400.

I forget, but is an exported RDD in a text editable format (like XML)? Maybe you could try exporting it, tweaking it outside of E10, and then re-importing it.

so that indicates there is no bug in the software

lol

I had not tried that, and from the test I just made it appears that I could go down that route next time. So that’ll work. Thanks!

I thought Support would want to do WebEx to see it on my system. But I guess RDD’s fall under the realm of “customizations”, which support turns away from.

While the RDD’s are used for customization, my issue was really with the system’s inability to remove the table. Which sounds like core functionality to me.

I’ve ran into similar support issues with GoDaddy. I was trying to do something with my own web page that they deemed “custom”. But my problem was with Core functionality of allowing a page to accept JSON, not my custom solution.

It’s weird where companies draw the line with support.

I was able to delete all references to a table in the exported XML to circumvent. Ran into this issue again today.