Report in System Monitor not showing last action

Anyone know why a report will show as success in history task but will not show anything in last action on the reports tab in System Monitor?

Our production planner complain all her job travelers are not printing and we have narrowed missing ones to reports with no last action in system monitor.

Kristine Fierce

We are setting this happen for another user as well. Does anyone else have random printing issues similar to this?

What is the 5th column?

And when it comes to printing issues, we have such long delays if choosing to print from the client. So we always use Preview, and then print from the PDF viewer when it pops up (also give you a second chance to check what you’re actually printing)

That is the last action column. We have been identifying that when the last action is empty no report printed. However - the History Tasks shows report today as completed however the Report Detail tab show nothing in the last action column.

We log quite a bit in the server log and I don’t see any errors or anything out of the ordinary.

We are seeing the same behavior in version 10.2.100.

Did you find a resolution to the issue?

1 Like

I have not found the reason for the behavior yet.

I am seeing this behavior in 10.2.400.

Is there a setting to enable this or is this still an ongoing issue?

This is a continued issue for us and happens randomly. Have not been able to pinpoint the actions to re-produce yet.

I see a few. and I was the user that made them.

I wonder if those are the type that show as an error on the History tab, with instructions to Preview it from the Reports tab, to see the actual error.

The ones I have looked at shows as Successful with no errors in the History Tab. That is what puzzles me the most.

I noticed when we upgraded, that archiving was set to 0 days, meaning it will not keep the report… before it was by default 1 day. Could that be the source of your issue?


Just did a quick test…

  1. Ran the OrderAck report in preview mode
  2. Closed the client program before the report finished processing.
  3. Waited a few minutes
  4. Re-launch client and immediately opened the System Monitor

System Monitor opened, then a few seconds later the report appeared in the PDF viewer. But since it hadn’t yet rendered at the time the Sys Monitor was opened, it showed:

After hitting Refresh on the system monitor, the Last Action of that row remains blank.

The history task shows it completed, with EndedOn of 10:36 AM. The Reports tab’s Last Action On is 10:45 AM (the time the client was re-launched)

Closed the client and re-opened it. System Monitor Reports tab still shows a blank Last Action.

Interesting. Our user does not preview the job traveler when she prints them, instead sends them directly to the printer. I have suspected that maybe she is too quick in her actions and your test makes me believe that could be the case. Asking her to slow down before moving onto the next job will be fun :slight_smile:
In her case she is still in job entry but would have closed the print dialog box and possibly entered the next job number to print before the previous one were done rendering.

I don’t think its the speed of using the various programs in E10. I think it is the fact that the System monitor updates task’s Last Action field. And since closing the client program closes System Monitor, the system monitor isn’t able to update the task.

If you close the system monitor, then preview a report, or print it to a client printer (one connected to the client PC), the preview (or print) won’t happen.

With the client program still open, if you then launch the System Monitor (Sys Setup -> Sys Maint -> Sys Monitor), the report will preview, or be sent to the printer. But the entry in the Sys Mon will still show a blank Last Action.

So I believe that any report that finishes processing, when the System Monitor is closed, will not render (preview or print to the printer) until the next time Sys Mon is launched. And the entry in the Reports tab will forever have a blank for the Last Action.

Any chance that user is closing the System Monitor (right click -> Exit)?

Or that System monitor is crashing on their workstation.

P.S. I have no idea, but would think that reports sent to system printers would print even with System Monitor closed, but their Last Action would remain blank.

User claims she has job travler not printing on and off from creating jobs from job manager, quick jobs and job entry. User is quite fast at hand “busy, busy”. I have tried to repeat but haven’t been able to yet. I’ll revisit her problem with your test in mind to see if I can find the trick to re-produce.

I don’t believe the user is closing the system monitor, however I will double check. Her process is to sit down and print a number of jobs in a row at the beginning of the day so she will jump from one job to another quite quickly. btw - we have tried to have her do mass printing with no luck yet.

I’ve not seen it in E10, but in V8 we used to have an issue where if you submitted a print job before the prior one finished, that 2nd job wouldn’t appear until you submitted a third one. And the third wouldn’t appear until you submitted the fourth and so on…

Unrelated to the above …

Check the Sys Mon Config settings on her machine/user. Open theSystem Monitor, and select Actions -> Configurations


1 Like

Hello Kristine, did you get to discover the source of this issue? we are having same behaviour on 10.2.400. We have users running Epicor through a TS client. Looks like system monitor disconnects, causing this issue. they need to log out/in to get all ‘pending’ reports being previewed in one shot.

@MisterG - When running on TS, the Session Manager should be run as a service on the TS server. Else it is tied to the first TS user that logs in. And strange things can happen when that TS user logs out, with other TS users still logged in.


In case you don’t have access to epicor support:

Details (click arrow to expand)


The default configuration has the Session Manager running in Standalone mode which is appropriate for client installers where only one concurrent Epicor session will be running at a time. On an RDS server however, if the Session Manager is not running as a service the user who first launches Epicor “owns” the session manager (it is spawned from their session).

When this user closes Epicor, the session manager that was spawned from their session is also closed, affecting every other user who may still have an active Epicor session on that sever. When that happens, it can cause unexpected results for the other users that logged into after the first user.


To CONFIGURE the Session Manager as a Windows service, complete the following from an elevated command prompt:

  1. Launch an elevated command prompt.
  2. Type the following and press Enter: NOTE: Change to the path of where the Epicor client folder is located on the computer.
    %WINDIR%\Microsoft.NET\Framework\v4.0.30319\InstallUtil /LogFile SessionManagerServer.exe
  3. Type the following and press Enter:
    net start “Manufacturing Session Manager” .

To REMOVE the Session Manager as a Windows service, complete the following from an elevated command prompt:

  1. Type the following and press Enter:
    net stop “Manufacturing Session Manager”
  2. Type the following and press Enter. NOTE: Change to the path of where the Epicor client folder is located on the computer.
    %WINDIR%\Microsoft.NET\Framework\v4.0.30319\InstallUtil /u /LogFile SessionManagerServer.exe
1 Like

mmmm… will surely need to check this. thx

Calvin you made my day!
this truly fixed our issue