Rest API MES StartActivity

I have found a bug in the help when using the “Switch to Custom list” link for api/help/odata/Erp.BO.JobEntrySvc/index to get “ValidateJobNum” method I get an unresponsive script message and my browser crashes. I have tried different browsers, tried Chrome x64 with no luck .

Has anyone had any luck accessing that service, and could either provide me the details for it or a workaround.


That is not a bug, the amount of methods on this list is really large. You just have to wait it out, if it says un-responsive click Wait. and keep waiting. It can take several seconds to render. It will render eventually if you wait long enough

We need to work with the Swagger community to enhance Swagger and submit a PR to deal with large services. When you look at that help page think about every method, every column, all the text on the fields… throw all that data back at swagger and it takes some time to chew on it. Many times a simple CPU / browser simply stops breathing. If you wait long enough many times it will recover (~2 minutes on large services / lower hardware and browsers).

We need to do some work to make swagger incremental in it’s data gathering. We just have not had the bandwidth to engage with them yet. The alternative is to split up the larger services into smaller services and break a few hundred customers integrations. That suggestion did not go far internally for obvious reasons :slight_smile:

1 Like