REST API - Post/Patch Permissions

First post here so be kind…
Love the REST API functionality, so far just used it to extract data. Currently working on an app to load data to the serial number table.

We are multi-tenant hosted.

I get the attached error when trying to Patch. Question: Because I’m MT Hosted are we unable to write? Do I have to have permissions to do updateable BAQ’s?

Any help would be appreciated.

The error response is the general bucket error ‘Something went wrong’?
(And yes, I just finished the the first draft spec on real exception returns so thanks all for feedback this last year).

edit - reread your screen.

Pester MT folks for the text on that error. They get those calls too often (And why I need to get you folks tools to read these errors)

1 Like

I think you need to pass more fields. As hosted you don’t have access to event viewer. I would ask support to turn off custom errors so you can see the actual error in the response


@josecgomez Do you think we need to pass all the fields?

I’ll call support but haven’t had very good luck getting any information around REST API from them.

Does anyone have a sample of successfully passing data in through the web interface?

Try passing the entire model from above back in the below. At a minimum to make life easier in troubleshooting, do make sure to as Jose said “ask support to turn off custom errors so you can see the actual error in the response”

This is UpdateExt internally, there is no need to pass all columns.
Try to enclose Company and Part parameters in quotes ’ ’

1 Like


Single quotes, @Olga is correct. I ALWAYS get bit by the quotes, especially decimals.

I’ve tried ‘ ‘ on the Company & Part Parameters and not on the Serial Number Parameter. Same error. Tried ‘ ‘ on all 3 and same error.

We will need to test the underlying service. You don’t have BLTester so we will need to annoy the support folks.(Hmmm… conversation time with the Product Manager of SaaS)…
I think I just got pinged on this so assume you filed a ticket? (CS0000639765)

That’s my case…

1 Like

@Olga, @Bart_Elia

I tried to create an updateable BAQ to do the same thing and was getting an error. Called TS and the Rep had me add “SNMaint” --> TransactionSource and it worked on the BAQ. Thought maybe it was related and tried it on the REST Patch and it worked. Seems like TransactionSource should be a Rq’d field.

1 Like

Both UBAQ and PATCH in REST are working with UpdateExt functionality of the business object. So yes, they both will require similar field, like TransactionSource here.

1 Like

This is something being discussed internally - how to determine required fields (or ranges) based upon the state of the record.

For a PK that is easy to light up.
For other fields, how do we indicate ‘required because of ‘x’’

It’s an interesting challenge.