REST call timeout in third-party app

I am working with an app called Tulip.

  • We are integrating Epicor ERP with it via REST
  • Tulip is all on the cloud
  • It has worked fine so far and I have been happy with it.

Yesterday, though, we had intermittent failures. I’d run the exact same REST call over and over (back to back) and get differing results. (20 seconds is Tulip’s limitation.)

Attempt Result Time
1 Fail 20 seconds
2 Fail 20 seconds
3 Success Immediate
4 Success Immediate
5 Success Immediate
6 Fail 20 seconds

But in Postman (or BAQ Designer), it worked perfectly every time. (GIFS below)

Today, of course, it all works flawlessly.

Any thoughts as to what could have happened? Was it Tulip? Or the local Internet provider? I don’t know how the infrastructure works, so I am at a total loss at this point.

Tulip tests GIF

Postman tests GIF

If it was intermittent from tulip (than postman local) I’d say it was a network issue from their side. Some route issue from them to you, or you to them.

Hmm. OK. I put a ticket in with them yesterday, but they didn’t find anything (just verified I was not crazy).

It’s just scary, because we want/need to rely on this working for our future plans of getting real-time info to the shop floor, and eventually in the reverse, to put info into Epicor.

I guess my point is, you don’t think it’s something with our building being in the backwoods of South Carolina?

bahaha probably…

Rats.

Is there a retry option?

I feel like I have seen that somewhere, but it’s not jumping out at me. I’ll keep looking.

Normal response for this is well under a second. So really I feel like saying, try for 5 seconds, then retry 4 times more. I don’t need it to try for 20 seconds every time. I doubt it’s that granular, though.