Rest-erp filter behavior on JobEntry / JobTracker isn't resetting to updated values

Doing a relatively mundane screen enhancement but I figure I must be missing something about how the data views / tables are being updated.

I am trying to make a text box bind to the Part table on a Job Entry kinetic customization layer.

What I’ve tried doing is obviously binding to the Part table that’s built into the screen. Mine returns no value, so I’m assuming it never gets bound. That’s fine, just went down this rodeo on a custom dashboard.

I created a new data view, called PartCustomer (I’m bringing in some customer fields we added to our part table).

I created an event for updating this data view with rest-erp action. The action works, and binds the results properly, however, it only shows the customer of the first job selected. Every time I search a new job after, it continuously filters by the first job I loaded on the screen.

I am currently binding to the After Event for ColumnChanging_JobHead_JobNum


I initially tried binding to the Dataview Changed for both view and row for both KeyFields and JobHead views, but neither would detect the PartNum field to run the rest-erp action against.

Other events I’ve tried are:

I believe one or two of these only worked on the search result set and didn’t work from the landing page, but all of them experience the same issue where the rest-erp “whereClausePart” method parameter isn’t updating to the new JobHead.PartNum that gets selected.


My debugger consistently shows the same part number. I thought maybe the table wasn’t being cleared out so I also set up a data-clear, but I can visually see it clearing and the console in the developer shows it searching under the first job’s part number each time no matter how many times I search a part.

I know my rest-erp is working because when I set it up on the On Blur behavior on the JobNum field, it works as expected, however, it needs to update alongside the rest of the fields visually and not be waiting on a click / tab to elsewhere on the screen.

Maybe I’m overcomplicating such a simple data display. Hopefully over the next few weeks I won’t be such a frequent flyer on here lol. Any ideas?

Thank you!

Weirdest part, currently bound to AfterGetByID

When I do a dialog-show, the part number is showing up correctly from all areas selected. Not sure why the After Event trigger isn’t working.

EDIT - Same behavior swapping out the rest-erp from GetRows with a filter to a straight GetByID with it using the field JobHead.PartNum

I thought I had tried JobPart and that it was empty, but JobPart DOES at least keep updated with the JobHead / KeyFields. I was able to delete my custom view and use this instead.

Despite being the correct part number on the table after all the events are done running, the rest-erp method still does not correctly switch to the next part number.