Row Already belongs to another table

Support says now the target is .9

3 Likes

Ugh, this killed my day on monday. I was migrating RDDs and thought they were broken unitl I found this here.
Live is still 2023 so I worked in there and moved to Pilot :slight_smile:

yeah, i may do this as well. I didn’t want to play around in LIVE… but I guess I can make a new copy… fix what I need to in LIVE… and then port it over to PILOT to continue my project.

Same thing we are doing but cloud goes to .8 next week so I’m hoping we can get a hotfix. Completely unacceptable to not be able to modify RDDs.

They said it would be fixed in 2024.1.8 but it hasn’t been. Got a notification this morning on Problem PRB0282390 that it’s status had been changed to “Work In Progress”

I did find that I could add a new relationship(clicking through the errors) and set the relationship fields by selecting one of the Keys defined for the table

That bought in the Relationship Fields I was looking for. That’s the only way I was able to set them

2 Likes

You can use a UBAQ as a workaround to make changes to RDDs that the error is preventing you from doing in the UI.

Has anybody found the root of the issue and how to workaround it? Getting this error on multiple RDDs for different Customers is driving me crazy, so time consuming to manually update through a uBAQ or create it on a different environment that has not been upgraded, not to mention that even the Standard RDD displays the error so you carry it when you create a copy. I am so not looking forward for the Upgrade in Production this weekend!

We are getting the same in our Pilot, among many other issues. If the actual update goes as horrible as the pilot has, we are in for real trouble.

1 Like

I guess it’s not only me with the same issue, most part of the world got issue

Epicor now has a fix. The cloud team deployed it in our instance this morning and we now have a working Report Data Definition Maintenance program once again. Before this, I used REST to call the BO to add the relationship fields. Its the long way 'round, but it worked.

1 Like