Scheduled report with E-mail params error out

Hi everyone,

I have a user who has set up a report to run on a schedule with e-mail parameters and it was working. suddenly this month the reports are giving an error that the email address is empty. I am wondering if anyone knows where epicor stores this information so that I can fix it.


Try to open the print dialog in epicor and then do Actions> “restore defaults.” it could be that a blank email was saved as a default.

Then reschedule it.

We are trying not to reschedule it there are quite a few reports that this would have to be done for.

Each task shows up under the schedule in the system agent maintenance, and you can view the task parameters. We don’t use e-mail for ours so I’m not sure about that part, but I think it’s where that lives.


@Banderson is correct, you can view how you scheduled it there. What I am thinking though is that there is a saved default with a blank email for that report print form.

@MattSpotts does this happen even when you email it outside of the schedule?

This worked even inside the schedule. It is within the last month that it stopped working. It has to be something with the way the parameters are stored because there is an error with one of the reports when I view the parameters. It says “Part is neither a DataColumn nor a DataRelation for table StockStatusReportParam.”. If I could figure out where epicor stores this information I would be able to find and correct the problem. I am assuming it is an XML file somewhere.
The report params are easy to view and all but the Email is only entered when the print button is hit and then the information entered on the E-mail table of the print dialog box.


Does it work outside of the scheduled process? Can you run it manually?

That is why I am saying the issue is with the form defaults. There is a table called ice.SysTaskParam and I think you can use it to find the task that you are having issues with and then you can find that property. If it is blank then you should try my suggestion.

Yes it works outside of the task when i run it manually

That is very strange

ice.SysAgentTaskParam … Query that table and find your task. It will have an EMailTo field.


I am doing that now. That is what I think i am looking for. Thanks Utah I will report back if i find something.

FWIW - we had some issues when an email address field (To, CC, BCC) had trailing spaces.

These would creep in when multiple addresses were used like:;;

If the; is deleted, it left the address ending with a semi-colon, followed by a space. This would cause errors.

And I never try to use the style where the display name is included like:
Joe Smith <>

1 Like