Setting columns permissions doesn't seem to work with Field Security Maintenance

Hey

So I have a custom bool column that’s bound to a checkbox and in the Field Security Maintenance I’ve set the Default Access to be Read and I only want to set a few users to Full.

Now the users that I want to set to have full permissions (myself included) are all Security Managers but the Access options for these users are read only and set to Default (which will be Read) so I can’t change them to have Full Access.

I thought I might as well see if the Default Read Access works since I’m a security manager and can’t change mine to Full either but it still let me change the checkbox bound to my custom column and it appears to save this change to the database.

Am I missing a step in the process?

Cheers

I’m seeing full access on my end. May I know which table are you trying to set?

image

It’s the Part_UD table, I didn’t realise you could post images here, I’ve screenshotted what I see for my security manager accounts:

image

Mine also greyed out for the Sec Manager. If I’m not wrong, I believed that Sec Manager trump the Field Security no matter if you set to Read Only. I also when in and give this a little test like you did from the above post and I was also able to update the field with Read Only as Sec. Manager.

image

Ah yeah you’re right, I removed my security manager permissions and it appears to have stopped me being able to check that checkbox.

Cheers for that mate!