Shared SSRS Reports Site and DB between App Servers

Hi Everyone,

I have setup our E10.1.600.x environment to have a secondary App Server, that points to an existing database, but that uses a different tcp binding, to allow SSO Win Auth logins. I tried to configure the new App Server to use the same SSRS report site already deployed for the primary App Server, however, when I run a report in Epicor, after configuring the SSRS reports tab and adding a Windows Auth Task Agent, the report returns an error to the monitor and no report is printer out.

This is the error on the report monitor:
Program Ice.Services.Lib.RunTask raised an unexpected exception with the following message: RunTask: System.Web.Services.Protocols.SoapException: The item ‘/reports/BookListingReport/GlBook’ cannot be found. —> Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item ‘/reports/BookListingReport/GlBook’ cannot be found.
at Microsoft.ReportingServices.Library.ReportExecution2005Impl.LoadReport(String Report, String HistoryID, ExecutionInfo2& executionInfo)
at Microsoft.ReportingServices.WebServer.ReportExecutionService.LoadReport(String Report, String HistoryID, ExecutionInfo& executionInfo)
Stack Trace:

Is it possible to share the same SSRS reports site between two or more App Servers?
If each App Server needs its own SSRS reports site, can they all use the same SSRS report database?

Thanks in advance.
Carlos Quintanilla

It is possible to share reporting services between both application servers and should be the only way you would want to set it up. I just configured two application servers, with different bindings. Does your user account in the task agent have single sign-on permissions and do you have the SSRS urls setup correctly? If you run EAC on each server you should have identical SSRS settings. Check your root folder. That seems to be missed quite often.

Hi Dan Edwards,

Thanks for the info. That’s definitely what I want to setup because I do not want to customize a report and have to deploy it N times.
Where do you see that SSO permissions? I did follow what the epicor doc says.

This is my setup:

App Server 1
Tcp Binding: UsernameWindowsChannel
App Pool uses custom account: DOMAIN\adminuser

SSRS site: http://SERVER/ReportServer
Folder: EpicorTest10
DB: EpicorTest10Reports

Task Agent:
user: print

App Server 2
Tcp Binding: Windows
App Pool uses custom account: DOMAIN\adminuser

SSRS site: http://SERVER/ReportServer
Folder: EpicorTest10
DB: EpicorTest10Reports

Task Agent:
user: empty/disabled

The Windows EpicorICETaskAgent3.1.600.0 windows service has a Custom Logon:
This is because epicor doc tells you to use an Admin account.

The account used for the service is an admin account that is sysadmin on SQL Server and has also been explicitly added to the SSRS website security.

As a test, I assigned the DOMAIN\adminuser account to the manager Epicor user account.
If I use this new App Server 2 client, I can access Epicor using SSO, but I still get the report error.


The configuration you have should work just fine. Did you deploy from the EAC on App Server 2 once you had the SSRS configuration setup? You do this with import reports unchecked.

One more thing - if you check “Require Single Sign-On” in the user account setup, you will need to make sure and have task agent rules to make sure requests from users with SSO required are routed to your single sign-on enabled application server or it will error out.

Thanks Dan,
At the end, It looks like I missed an App Pool or Task Agent restart. SSO with reports is now working properly.