Single user is unable to use a dashboard


We have a dashboard that one user cannot get it to refresh.
Other users can use this dashboard fine.

I thought it might be a personalization issue, except when i turn on developer mode and try to assess this dashboard I don’t see the developer mode screen to delete personalizations. (the screen that pops up when you have developer mode turned on doesn’t pop up and dashboard just opens).

Does anyone know how to delete personalization on inhouse created dashboard?
Has anyone experienced something similar to us?


May be worth checking the “Personalization Purge” module to see if it can be cleared from there.

I didn’t know about “personalization purge” thank you. However they didn’t have the inhouse dashboard personalization.

Now i am not sure how to fix this error.

I’ll just create a case with Epicor.


Going down the road of personalizations being the issue, have you tried to clear them from the users PC. Have the user open the report, and right click around where the header is (report description/name) and “Reset Layouts to base”?

I have cleared cache on their computer, and also tried reseting layout to base and it still didn’t work. :frowning:

@sbang You can do a super clear cache or remove the folder under C:\ProgramData\Epicor for your client install. Only do this with Epicor closed. The folders will be rebuilt on the next open. These are some samples from one of my PCs.


Does this dashboard fail for this user on other computers? Does it fail on this PC if you logon with another user?

If the user saved the dashboard to favorites, and then any modifications done to the dashboard after they did so, will often create issues. I’ve had to have users delete the dashboard from favorites before, and then re-add it to resolve the issues they were having.

Just in case the other suggestions don’t resolve the issue.

You can also delete personalizations from the Customization Maintenance under System Management. When you click on the “Name…” search button, set Type as personalization, and then look for the user/dashboard you’re wanting to delete.

If a user accidentally sets multiple column sorts between Save Layouts (save a sort, then change the sort to a different column and save again) it will often cause the dashboard to fail on them.

Thank you everyone :slight_smile: it turned out it was a Work Force set up… I had to let this user have “view all territory” turned on at Work Force level.


Please mark the answer as “solution” for the benefit of future readers. Even if you solved it. (And kudos!)