Specific User MtlTags printing incorrect information

We have a user that appears corrupt or something. If possible, we would like to not delete and recreate or deactivate and create new.

When unlinked from the Employee, it prints fine on just the employee in MES.
The issue happens on only one user, both in Epicor and MES.

The issue: The user saved a nonconformance entry. Now in every Print MtlTags screen (End Activity, Move WIP, Some custom screens), it generates a report with the incorrect PartDescription, Bins, and includes a nonconformance number at the bottom, regardless of the job number being printed. Basically, all of the nonconformance job information is put onto every tag the user attempts to print.

This issue was not present until yesterday. We have tried elevating her privileges, creating a new nonconformance (which worked, and printed correctly, but every subsequent tag has incorrect info referring to the original issue nonconformance). It is not the SSRS because there are fields from the same table that are correct while some are incorrect. It is also not the report style, we have tried multiple styles and they all present the issue for this user only. As far as we can tell, there is something corrupt with the user or some table being referenced by the user that is incorrect. There was a plant wide connection issue that may have occurred during the transaction, but I am not sure if it coincided or not.

We do have a testing server where the issue is not present. Is there a way to export a user and all associated files and re-import them? Should we delete the user and recreate the same named user? I’ve seen posts warning against deletion of users, what are the reasons for this? Or is deactivate and create a new one the only viable option here?

EDIT - Deleting and recreating did not fix her user.

A lot of questions.

Thank you,
Logan S.


Is the MtlTags report custom or has it been modified?

@LoganS the only time I’ve seen this is when the user unintentially set Save Defaults while printing.
Try this:

  • Login as the user (MES or Epicor)
  • Open one of the Print MtlTags Screen
  • Select ‘Remove Defaults’ from the Action Menu
  • Close the Print window, Repoen and try to print.


Everything is unfortunately modified a little, however, it is just the single user experiencing issues across any PrintTags screen (except, apparently, the Actions → Print Tags in non-conformance)

The SSRS report has been modified recently, but, the issue persisted on all old report styles from the past that are still in the system. It also only happens on the single user, where the report prints fine on all other users.

The EndActivity version of Print Tags that it calls I do not believe has been updated in quite a few months, if not over a year.

Our newest print screen seems to work fine as well, except for the single user.

The only change I made recently to tags was passing and clearing Environment Variables to try to bring in some fields that seemed inaccessible any other way. This was a couple weeks ago now, but there have been no reported issues with it so far. We tried deleting the user and readding them with the same name and the issue persisted. This is leading us to believe there is a temporary table somewhere for passing parameters to reports per user that may have gotten hosed up somehow, maybe from a dropped connection right in the middle of a transaction critical step?

I did attempt to set defaults to base, and purged all personalizations. Issue persisted sadly. I’m off for the rest of the day, so I will pick up again tomorrow. Thank you.

Does the report run okay for the base Report Style? wondering if this is a long lingering/dormant issue. Could you post a screenshot of the rdd with the tables/relationships? as well as the SSRS SQL Query?

Actions > ‘Remove Defaults’ is not the same as Tools > 'Reset Layouts To Base’
Actions > ‘Remove Defaults’ is DATA defaults.
Tools > ‘Reset Layouts To Base’ is the UI Layouts.


Yes, this worked!

1 Like

I just happened to have this exact problem, thanks for saving my morning!