SSRS Root Folder Problems

I have updated my live to 10.1.400.37 and when runnign reports, it says not found. However, In the report server, I can see them. So I got to looking at the app server and it has the root folder lsited. When I opned the root folder via the website address, it shows hardly any reports. But the ones that are there work. However, the root folder isn’t showing up in the report server…or am I just stupid and am missing something?

When you deployed this version did you make sure to check the “deploy Ssrs reports” box in the admin console?

That under Reporting services in the admin console?


I have selected Configure SSRS, entered the webs service URL, Selected the root folder, enter the database connection piece, and selected import reports.

There should be a checkbox can you screenshot

Ok and you deployed with those settings?


Not sure…if I were you I’d retrace my steps and redeploy according to the instructions. It doesn’t make sense that they would have changed

Yeah, that was my thought. Thing that got me is why is it reading from the root folder and not from the regualr folder like it did before?

I’d have to look at my config but I would imagine your root folder wouldn’t change.

All I did was run the 10.1.400.37 pack, select it in the app server, then re-deployed. Changed nothing else, and everything else is working but the reports.

When u deployed, did it run through the part of the deployment where it said it was writing all the report files to the server?

I was expecting that to happen, but it never did, ever. And that is why I was thinking taht when I access http://SERVER NAME/ROOT FOLDER/Reports I can see afew reports in there. I just don’t know how to put the reports in there.

Does the root folder exit on the report server?

No, I do not see it.

Create it and then make sure it matches your config in the admin console area for root folder then redeploy

matches config? Explain a bit, I understand the name must be the same.

Yep just make sure the name is the same. I called mine “reports”, but I could take a look to make sure and send screenshots on Monday