SSRS: sub report can not be found

(Just a mental lapse I think)

I have a canned report I just need to add a customized sub-report into it. I created the sub-report and it works fine. Every time I run the main report, it keeps saying it “sub report cannot be found”.

In the subreport properties, how can force the same path as the main report (rather than the entire path)?

I do not want to use (as an example):

/epicorserver/reports/customreport/mysubreport1 BUT just:


Did you place the custom sub-report in the same folder as the main report AND re-point the main report to the new sub-report?

The sub-report uses the same datasource as the main report. The datasource and dataset are the same.
Yes, the sub-report is in the same exact folder as the main report.

When I right-click the sub-report, I browse into the same folder as the main-report. But, then the end result is a long path like “/epicorserver/reports/customreport/folder/mysubreport1”. I just want the subreport reportname to be “mysubreport1”.

What am I missing?

I even tried to making a linked report within SSRS, but that did not work. I know I have done this before with success. I am just forgetting a small detail somewhere.

Just as example:

The A/R Customer Statement RDL has 2 embedded sub-reports in it. When I go to download the main-report, where does it “know” it has 2 embedded sub-reports and downloads those as well.
I basically need to “tell” Epicor I have embedded an additional sub-report in it but I do not know where I can do that.

You have to use the custom reports folder to store customized reports, at least to my knowedge. You’ll be glad of that when you perform an upgrade, since it will re-write the top level reports but will not touch the Custom Reports folder.

Yes, yes. I know this…I AM using the \CustomReports folder.

The previous attachment was just to demonstrate that when downloading a Report (w/sub-reports) from Epior, somehow it knows that there are embedded sub-reports in the main report.

I am trying to figure out where I need to “tell” Epior that I do have an embedded sub-report.

I do not know why, but when I run the customized report with an additional sub-report, for some reason it cannot find the sub-report. At this point, I think it might be something else perhaps…like a wrong parameter linking the main-report to the sub-report. SSRS is just throwing that error because it does not know the correct message. …guessing.

Is the subreport pointed at the same datasource