SysTask process fails

I have scheduled task that have been working perfectly until last night when they all ERRORED with the following:
Program Ice.Services.Lib.RunTask when executing task 27476 raised an unexpected exception with the following message: RunTask:
Ice.Core.SsrsReporting.SsrsCaller.SsrsException: 2026-09-01 08:00:01.01 UTC The SSRS server returned the status code 500 (InternalServerError) with the following error text:
System.Web.Services.Protocols.SoapException: The item ‘/reports/CustomReports/AST_TM_AUDIT/AST_TM_AUDIT’ cannot be found. —> Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item ‘/reports/CustomReports/AST_TM_AUDIT/AST_TM_AUDIT’ cannot be found.

I logged into SSRS and the files were there and no permissons have changed. I then login in manually and run them and some times I the ran manually and other times errored with the same error. I stopped and restarted the SysTask agent and that did not help. I restarted the SSRS windows service and that seemed to not only consistantly run with SUCCESS but also quicker.

Any thoughts on root cause and to prevent from happening again would be appreciated.

Did you already look at the SSRS logs? are you on prem?

I found the issue. Apparently in the SSRS root there was a seperate folder just created yesterday called reports. The folder that would normally be in the {environment} from the root. So instead of LIVE\Reports it was \Reports. Which explains the not found error. Why and how that got created I do not now. But ended up rebuilding the Live depoloyment and that seemed to have fixed it.