Unfirm jobs with no BOM

Hi there,
We’re upgrading this weekend from 905702 to 10.1.600.5. We initially planned upgrade to 10.1.500.xxx but upon experiencing and then reading about other’s MRP problems with no details getting pulled from approved revisions for unfirm jobs on particular parts, we decided to go to 10.1.600.5 to try and alleviate the problem.
We still have several unfirm jobs with no details despite having an approved revision.
Anyone else using MRP on E10 and having problems with job details not getting pulled for certain parts? Any solutions?


More detail on error I see: if I have a phantom BOM setup for a part with part rev in another plant, then the job for a different plant that uses same collection of parts on a job does not get details pulled. There’s no operations, it’s just a collection of parts… this used to work in 905702 :frowning:

We’re actually have a similar issue with Configurations that when we try to pull Job Details it just gives us:

An error occurred while reading from the store provider’s data reader. See the inner exception for details

We’re working with Epicor on resolving this issue, but as of yet there’s no solution in place. In our case it doesn’t happen all the time so that’s what makes this issue problematic.

They have released patch 10.1.600.7. I’m loading that as we speak, have you tested that patch yet?

Hi Jonathan,

Thanks for the notice. We just discovered yesterday (went live 10.1.600.5) that we cannot manually pull job details on a parent with a phantom bom that is different part rev plant from parent job either. … thought it was just MRP empty unfirms… now engineering is really ticked :frowning:

We have not tested the .7 patch… struggling with some go-live issues on our .5 still. Let me know if it fixes it for you?


Just as an update:

Epicor released 10.1.600.8 that seems to address all of the issues with Phantoms and Job Details. We’re testing that now as we speak and so far have had good results.

We are currently on 10.1.500.26 and are getting the same error in our MRP logs. When this happens we are also getting unfirm jobs for those parts with no details in them. If I run MRP on those parts then it processes fine. It seems to break all of our MRP process threads for about 3 mins at a time, every MRP run. I end up with 8-15 parts every morning with MRP log error that says “An error occurred while reading from the store provider’s data reader. See the inner exception for details” Did you ever resolve what was causing this? We are currently working with Epicor and they are adjusting the MRP.dll code as they think MRP is simply tripping over itself when processing. I cannot believe that we are the only people on the planet that are having this issue though. Any updates on this topic??


Currently Epicor is working on the issue. We have the ball rolling on a fix: PRB0188025 and SCR 207237, but this has been an ongoing problem dating back to July 18th, 2017 for a solution. Please call Epicor Support and reference the PRB and SCR above. We currently have 12 companies on this ticket. It does need to be corrected as it has complicated our configuration model deeply.

Jonathan Lang

We have a release date and release number:

Release Date: 11/10/2017
Release Number: 10.1.600.15

If that’s what stopping you from going live on Epicor 10 that’s you fix. Epicor is recommending you start testing that is scheduled for release by the end of November, don’t hold me to that date.

SCR 207237 is listed in the 10.1.600.15 patch notes but references description of: Order Job Wizard - Get Details for a configured part generates an error. This is under the Sales Management - Order Management section. We currently don’t use the order job wizard or configured parts. However we are still getting defunct part errors and unable to read from stores data provider reader messages at random in our MRP logs. Is this SCR still related to these messages? We are now currently live on 10.1.500.31. Do you think this SCR would fix our MRP problems? Will this SCR be applied or available for 10.1.500 version?

In our case it looks like I will have to provide a business case to Epicor in order to get this fix applied to 10.1.500 so that MRP will not take so darn long to get details when creating jobs during the MRP run and causing time outs and/or deadlocks.

Here is what I got from Epicor on the original SCR 207237:

Yes, the details on SCR 208632 are the same. Development basically created this related SCR 208632 when an update request (one-off) was requested for a different version. SCR 208632 was created/released with 10.1.600.15.

SCR 208632: UpdReq600 - Order Job Wizard - Get Details for a configured part generates an error.

When trying to create a Job using Getting Details for a configured part, the system hangs and generates an error(It takes a long time to see that error).

No error should be thrown and it should not take as long to get details and the job has to be created.

**Additional Info: **
Review also creating the job from Quote, and also running MRP

Application Error
Exception caught in: Epicor.ServiceModel
Error Detail ============Message: An error occurred while updating the entries. See the inner exception for details.Inner Exception Message: Lock request time out period exceeded.The statement has been terminated.Program: Epicor.ServiceModel.dllMethod: ShouldRethrowNonRetryableException
Client Stack Trace ================== at System.Data.Mapping.Update.Internal.UpdateTranslator.Update(IEntityStateManager stateManager, IEntityAdapter adapter) at System.Data.Objects.ObjectContext.SaveChanges(SaveOptions options) at Ice.IceDataContext.SaveChanges(SaveOptions options) in C:_Releases\ICE\3.1.600.9\Source\Framework\Epicor.System\Data\IceDataContext.cs:line 352 at Ice.IceDataContext.Validate[TLinqRow](TLinqRow row) in C:_Releases\ICE\3.1.600.9\Source\Framework\Epicor.System\Data\IceDataContext.cs:line 311 at Erp.Services.BO.OrderJobWizSvc.createjob() in c:_Releases\ERP\RL10.1.600.0\Source\Server\Services\BO\OrderJobWiz\OrderJobWiz.cs:line 1111 at Erp.Services.BO.OrderJobWizSvc.processJWOrderDtls(String& OP_ErrorMsgs) in c:_Releases\ERP\RL10.1.600.0\Source\Server\Services\BO\OrderJobWiz\OrderJobWiz.cs:line 2736 at Erp.Services.BO.OrderJobWizSvc.CreateJobs(OrderJobWizTableset& ds, String& pErrorMessages) in c:_Releases\ERP\RL10.1.600.0\Source\Server\Services\BO\OrderJobWiz\OrderJobWiz.cs:line 1379 at Erp.Services.BO.OrderJobWizSvcFacade.CreateJobs(OrderJobWizTableset& ds, String& pErrorMessages) in c:_Releases\ERP\RL10.1.600.0\Source\Server\Services\BO\OrderJobWiz\OrderJobWizSvcFacade.cs:line 83 at SyncInvokeCreateJobs(Object , Object[] , Object[] ) at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) at Epicor.Hosting.OperationBoundInvoker.InnerInvoke(Object instance, Func2 func) in C:\_Releases\ICE\3.1.600.9\Source\Framework\Epicor.System\Hosting\OperationBoundInvoker.cs:line 59 at Epicor.Hosting.OperationBoundInvoker.Invoke(Object instance, Func2 func) in C:_Releases\ICE\3.1.600.9\Source\Framework\Epicor.System\Hosting\OperationBoundInvoker.cs:line 47 at Epicor.Hosting.Wcf.EpiOperationInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) in C:_Releases\ICE\3.1.600.9\Source\Framework\Epicor.System\Hosting\Wcf\EpiOperationInvoker.cs:line 23 at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc) at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)
Inner Trace:Lock request time out period exceeded.The statement has been terminated.: at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action1 wrapCloseInAction) at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady) at System.Data.SqlClient.SqlDataReader.TryConsumeMetaData() at System.Data.SqlClient.SqlDataReader.get_MetaData() at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds, Boolean describeParameterEncryptionRequest) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource1 completion, Int32 timeout, Task& task, Boolean asyncWrite) at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method) at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method) at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior) at System.Data.Mapping.Update.Internal.DynamicUpdateCommand.Execute(UpdateTranslator translator, EntityConnection connection, Dictionary2 identifierValues, List1 generatedValues) at System.Data.Mapping.Update.Internal.UpdateTranslator.Update(IEntityStateManager stateManager, IEntityAdapter adapter)
at Epicor.ServiceModel.Channels.ImplBase`1.ShouldRethrowNonRetryableException(Exception ex, DataSet[] dataSets) at Erp.Proxy.BO.OrderJobWizImpl.CreateJobs(OrderJobWizDataSet ds, String& pErrorMessages) at Erp.Adapters.OrderJobWizAdapter.CreateJobs(String& pErrorMessages) at Erp.UI.App.OrderJobWizEntry.Transaction.CreateJobs()
Inner Exception ===============Lock request time out period exceeded.The statement has been terminated.

Using a Non-Configured part that has the same Method as the configured part does generate a job but takes a long time to generate the job.