Updateable Query - Task CheckComplete


I’m attempting to create an updateable dashboard for Tasks so the users don’t need access to Engineering Workbench, as our engineering team wants to add one of their processes as a task set.

Currently, the built in UpdateExt on Task and TEApproval give an error

I am assuming this is because somewhere in the methods it is calling CheckCompleteIncludingNextTaskWarning rather than what Engineering Workbench calls which is just CheckComplete

So, I turned off the BPM Update and toggled Advanced BPM Update only and started creating a BASE directive.

I filled in a dataset by query, and made sure to grab the real Task’s SysRowID rather than the Query result’s SysRowID just in case (either SysRowID does NOT work, tried both) and ran the Task.CheckComplete method in the BASE directive. The row says it updates without error, but nothing actually changes in the Engineering Workbench.

When I run CheckComplete in a pre-directive rather than base, and provide a dummy base directive or even run it in both directives, it also has the same behavior where nothing actually updates.

If I manually call the Update method in either the Pre or Base directive, it gives the “Row was modified by another user” error meaning the query must be calling the Update or UpdateExt on it’s own anyway at some point, but NOT AFTER the check complete directive fires like in Engineering Workbench.

I see there is a thread where @Aaron_Moreng completed a C# update to the Task properly, but as I’m unable to call the Update method without an error, I can’t really use this for my solution.

Any ideas or am I dead in the water?

EDIT* I also tried the same methodology in the RunCustomAction rather than the Update, with the same results.

Strange behavior discovered.

I noticed my Task didn’t have “NextTaskSeq” linked despite having a TaskSNxt record for it. In the Pre-Directive, I ran the CheckComplete as normal, and then set the Results field to the NextTaskSeq equal to the associated TaskSNxt NextTaskSeq.

Using this Pre-Directive in conjunction with the regular BPM Update for Task, it properly updated on the Task Table and created the secondary record for the Task that was next.

However, this does not reflect in Engineering Workbench!!!


Looking into why, possibly a difference between running Update versus UpdateExt, but again, it will not let me run the Update inside of the Pre Directive.

Running it without a custom BPM and only with the BPM Update as Task, it still breaks it this same way if I make NextTaskSeq updateable and manually specify task 20 / the next seq. So that means the standard updateable method is breaking it in this way.

See final post about how this solution actually started working despite originally not showing promising results.

No clue what did it, but it started working out of nowhere. I had toggled the BPM off, and it was still being out of sync. Randomly started working - turned the BPM back on and it kept working.

You can just have them use task list


I suppose that’s an option :sweat_smile:

They wanted an easier to navigate dashboard to quickly see the status of the entire task set alongside it, so this is kind of the format I came up with for them. Probably will hide most of the fields now that it is proving to work.

User with out work force approved user rights.

User with work force approved user rights.

1 Like