User on CRM license cannot see dashboard menu item


I have a user that cannot see the menu item for the dashboard I created. If they log in with a standard license they can see it. I made sure it requires the same security group as a different dashboard, which they can see. I also cleared the client cache and restarted Epicor. No luck so far.

Any ideas?

What menu did you put it under? Only some menus are available to CRM licenses, so it is probably not under one of those… Why don’t you try logging in with your account on a CRM license and see if you can see it.

You will need to put it under a menu a CRM user can see otherwise.

1 Like

OK, I logged in as CRM, I cannot see it either - but I can see another one I made under the same folder. I will triple check that it has the right security group I guess…

This is a custom dashboard or are you using a system form as the base?

Custom dashboard. Uses a BAQ that has rows from the Customer table and UD05

Just a guess, CRM licensing might not allow access to the UD table?
I wonder if it’s documented somewhere on EpicWeb/Epicare?
I know there is an MES answerbook that lists which items can access.

You can use UD tables, I have one of the UD forms used for CRM licensed people.

Can you take a screenshot of your menu maintenance and the security tab for the menu item also…

Maybe try making a new menu item and try again.

Have you checked the security ID of the menu item they can’t see? It may be different to the parent menu it is under, therefore they can’t access.

I have a similar issue to this. However mine is related to customizing the RMA Print Form. My user is able to access the Out of the Box version fine, but because I have a customization tied to a Non Menu Item it seems to be causing problems.

I tried creating a UBAQ to mark the CRMMenu checkbox in the Ice.Menu table so that it would allow it to be used in the CRM License… But that hack hasn’t seemed to work :smiley:

Did OP ever resolve this issue?

Hmm, I think it was something Epicor screwed up on an update, and they remotee in and fixed it for us. Sorry.