Using SSO on browser prompts me with a windows login, anyone know why?


I choose SSO as the login type on the browser, but then I am prompted with another windows login after entering my creds in the epicor prompts…

Yes, I have checked that they are typed in correctly…

Does anyone know why this might be happening.

Here’s what I get every time:


update: When I use domain\username in the Epicor prompts, then it works and doesn’t show me the second windows login screen.

Should we have to do this? Forgive me for any ignorance in asking that question :sweat_smile:


What browser?

1 Like

I’m so glad you asked this question. We have the same situation. I think the second prompt is coming from the windows server not from epicor but I don’t know how to make it stop. In our case entering domain\username doesn’t work (only username). We have people using both Edge and chrome.

1 Like

I am using Edge.

I would check the IIS settings for the instance. Is the windows authentication turned on?


I meant to ask this at insights :sob:

I’ll go check.

I am assuming it is turned on since it allows me to login when specifying the domain (which is windows auth).

Yes ours is enabled.

1 Like

I have logged a support ticket a few weeks ago right after the upgrade and apparently it is required at this point of time.

According to support, they have added Development Task TASK7247870.

I see this as disabling basic auth, not the windows pop up.

iv seen this and we had to add the app server url to the Internet security safe site list on the users machine. we are on prem

I tried that via internet options as a trusted site, if that’s what you mean… and it didn’t change.

The ticket I logged was why do I have to type in the password for the windows.

I am on prem, the reason I logged the ticket as I think the authentication for our App server is not setup properly.

Are you using Azure AD SSO which there is an option in the Application Server Settings.

1 Like

Thanks Toby, I don’t know why, but the task I was on was saying somethign about disabling basic auth.

How can I find this? Is there a PRB num?

The problem number is : PRB0254919


Thank you.

Toby, they came back to me and said that it wasn’t related, so I am not sure if something got changed up or what happened.

BUT, they did tell me the domain thing/extra windows security window was a bug, but couldn’t provide me the PRB because they didn’t have access to JIRA.

I had a brief discussion about SSO and Kinetic browser with an Epicor team member at Insights last week. He said that the Windows security popup was a known issue and should be fixed in 2023.2, possibly a patch to 2023.1. I don’t have any more detail than that, but it does sound like they are aware of it.