Vantage 8.03.403C - Cost Adjustment Error

Hi Lauren,

We had the same issue after updating from 305H to 403B - at least I
think it's the update that caused it.

Apparently each Plant can have a different cost per part, so the
PartCost table holds different records - one per Plant - plus a
reference to the Plant. If you open Plant Maintenance and look at the
Plant | Planning Data tab you can see the Plant Cost ID in the centre
of the screen. I suspect you will see 0 or nothing. In our case
that's what I saw and it should have read 1 - each of our PartCost
records had a CostID of 1.

I directly edited the database and changed the PlantCostID in the
Plant table to read 1. This solved my problem.

Nigel.


--- In vantage@yahoogroups.com, "Lauren Hellings" <LaurenH@...> wrote:
>
> When we try to open the Cost Adjustment screen from the
engineering -
> general ops menus we get the following error. We are unable to pull
up
> any part in our system in the Cost Adjustment screen. Yet when I go
into
> the Part Tracker and pull up a part the cost shows up on the Costs
tab,
> so I know there are cost records out there. Has anyone encountered
this
> issue? This was an upgrade from Vantage 8.03.305F.
>
>
> Exception caught in: Epicor.Mfg.BO.CostAdjustment
>
> Error Detail
> ============
> Message: Part Costs record is not available.
> Type: Error
> Program: bo/CostAdjustment.p
> Method: getOrigCosts
> Table: CostAdjustment
> Row:
> Field: PartNum
>
>
>
> Stack Trace
> ===========
> at
> Epicor.Mfg.Proxy.CostAdjustmentImpl.GetCostAdjustmentMultiple
(CostAdjust
> mentListDataSet ds)
> at
>
Epicor.Mfg.UI.Adapters.CostAdjustmentAdapter.GetCostAdjustmentMultiple
()
>
> Thank You,
>
> Lauren L. Hellings
> Systems Administrator
> Ericson Manufacturing Co.
>
>
>
>
>
> [Non-text portions of this message have been removed]
>
When we try to open the Cost Adjustment screen from the engineering -
general ops menus we get the following error. We are unable to pull up
any part in our system in the Cost Adjustment screen. Yet when I go into
the Part Tracker and pull up a part the cost shows up on the Costs tab,
so I know there are cost records out there. Has anyone encountered this
issue? This was an upgrade from Vantage 8.03.305F.


Exception caught in: Epicor.Mfg.BO.CostAdjustment

Error Detail
============
Message: Part Costs record is not available.
Type: Error
Program: bo/CostAdjustment.p
Method: getOrigCosts
Table: CostAdjustment
Row:
Field: PartNum



Stack Trace
===========
at
Epicor.Mfg.Proxy.CostAdjustmentImpl.GetCostAdjustmentMultiple(CostAdjust
mentListDataSet ds)
at
Epicor.Mfg.UI.Adapters.CostAdjustmentAdapter.GetCostAdjustmentMultiple()

Thank You,

Lauren L. Hellings
Systems Administrator
Ericson Manufacturing Co.





[Non-text portions of this message have been removed]