Vantage 8.03.403D - Editing Shop Employees

When we go to save change to a Shop Employee we get an error message
that a valid supervisor is required. The ID that is in the supervisor
field is valid. When we select the search function nothing appears.

We have been informed by tech support that this is a known problem
fixable by 8.03.404. We just went live on May 5th and management is not
wanting to upgrade just yet.

Does anyone have a suggestion for a workaround where we can make
changes to a Shop Employee (specifically rates) without getting this
error?

Thanks,
Wendy Hodgson