XL Connect 7.5

Hi,

I hope someone can help me. I have huge problems with installation for XL Connect 7.5
Basically on the server I have red triangle with exclamation mark in “Manage Connections”. Can anyone share screen shot and explain what I should enter there?
For me looks like simply task but not working! I tried enter “sa” user and password but cannot establish connection.

Many Thanks for any suggestions.

Can you supply a screen shot to jog my memory please.

error2

This should be a 30 sec. task and I spent already 2 days on it…

Agreed. I recall running into some issues myself… Just spinning up my Vm now and doing an XL connect install from scratch…I’ll let you know.

Thank you so much.

The documentation on page 9 Shows an image of the Epicor ERP Settings.
You need to create a new SQL Login using SSMS. Make sure it is Mapped to the EpicorERP database (that’s the field “Database Name” in the Database Connection tab of the Administration console the Application server you want to connect XLConnect to).

You also need to make sure the login has db_datareader rights.

Here is an example I’ve created a SQL login name BizAdminSQLUser and mapped it to the ERPDemo10.2.400 database.

I think this is the bit you might be missing.

Hi Simon,

Good thinking but I already double checked this and seems to be correct. Looks exactly like yours.

I think I will need someone to connect to my system to hold my hand and check everything again :slight_smile:

A couple of other resources you can look at are:

https://epicorcs.service-now.com/epiccare?id=epiccare_kb_article&sys_id=fdb9a959dbf3d70c6b16fa38bf9619a0
and


and

and

If you have specific errors that these links don’t help you work it out then. Log a case through Epicor, this is who you have your maintenance with. The Biznetsoftware support page mentions this. (at the bottom).

By the way I just blew my install up :frowning: so your not the only one.

XL Connect is one of those tools you can spend a hell of time getting it working then you don’t touch it for ages and you forget. So make sure you document what you did so you have it for next time.

I like this statement on Page 2…It really means nothing.

I believe it is trying to say Windows Installer - Turn Off Windows Installer Setting must me Enabled and set to Never…

And on another point, and I don’t like being critical, but I have to say the XL Connect install document is one of the worst…You can just about guarantee that there is a update and the updater runs before the EULA popup…

Hahaha I totally agree with your statement.

Thank you for all your effort !!. I have case open with Epicor now.
I will check all your suggestions as well.

Have a great week. I really appreacited what you did.

1 Like

No problems. And on a back of doing this and watching Jessica Jones…
I just thought of one other thing, which I am sure you have tried. Uninstall it all, remove your bizadmin user and the biznet server from your SQL server. If you are using SQL compact, then just uninstall it also. Then reinstall it from scratch.

Hi Simon,

Your last suggestion (uninstall all) was the one! Epicor support has nice tool from Biznet called Scrabber to check registry etc and remove all installed items. After re-install all is working perfectly fine.

Thanks again.

PS. They left the uninstall tool with me;)

That’s good to hear you got a resolution. Please mark your previous post as solved, so that others facing the same situation can find a solution quickly.

Cheers

Hi @JarSie

I have a working installation that I want to remove. There does not seem to be one uninstall. Do you perhaps have the steps and tool? On top of that I am getting this message which I am not sure whether it is related to XL Connect or something else on the server:
image
image
I have uninstalled other software on this server today.