XP MMC and Progress Explorer Tool

I had a similar situation with an NT4 server and WIN2K client on my
first test install. My solution was to edit the proexp.bat and
proexp.prm files to reference proexp11.msc in lieu of proexp.msc (one
line in each file). This enabled the Progress Explorer tool to launch
from the start menu on the server again.

John Elder
Penn State Tool & Die


--- In vantage@y..., ams@i... wrote:
>
> > I have run into a problem with the Progress 9.1C Explorer on the
NT 4.0 Server after running the Progress Explorer on my new XP Pro
Client. It seems like the MMC on XP modifies the file and makes it
incompatible with the NT 4.0 (MMC 1.1) tools.
Does anybody know a workaround so I can manage the databases on my
server once again? What files do I need to recover from backup?
> >
Thanks
> >
Mercer Sisson
> I have run into a problem with the Progress 9.1C Explorer on the NT 4.0
> Server after running the Progress Explorer on my new XP Pro Client. It
> seems like the MMC on XP modifies the file and makes it incompatible with
> the NT 4.0 (MMC 1.1) tools.
>
> Does anybody know a workaround so I can manage the databases on my server
> once again? What files do I need to recover from backup?
>
> Thanks
>
> Mercer Sisson
See if this EraNet article addresses your problem: 1708MPS

(Words from another user: After reading the doc, I got to thinking that maybe the issue was the fact that I ran Schema/Database conversions from my workstation. I'm running XP. 1708MPS offers a simple set of instructions that resolved this issue. Thought I would pass this on, because I'm sure many of you are thinking about/using XP. The price for living on the edge. -Les)

Page: 1708MPS
Summary: PG 9.1C error starting Progress Explorer Tool.
AnswerBook: Vantage ChangeRequests

PROBLEM DESCRIPTION: Running the Netsetup Causes MMC Error on Progress Explorer 9.1x
Error is: "The selected file is not a Microsoft Management Console document."

XA510

SUMMARY:

You cannot run Netsetup between Windows NT and Windows 2000 machines.
Each operating system requires a different version of the procfg.msc
file. Windows 2000 requires 1.2, while Windows NT 4.0 requires 1.1.

EXPLANATION:

If you run Netsetup on a Windows 2000 machine from a Windows NT master
installation, the tailoring phase on Windows 2000 knows it has to use
the 1.2 version. It renames the existing procfg.msc to procfg.11 and
then renames the procfg.12 procfg.msc. Once this is done, Windows NT
(which needs 1.1 to work) fails.

You encounter the following error when you launch Progress Explorer on
the Master Install:

The selected file is not a Microsoft Management Console document.


SOLUTION:

1) At the server, using Windows Explorer open the C:\Epic51\Progress folder.
2) Locate the Proexp.msc, rename it to Proexp.old
3) Make a copy of the Proexp11.msc.
4) Take the "Copy of Proexp11.msc" and rename it to Proexp.msc.
5) The older version of Proexp.msc should now open just fine on the NT server.

** The problem will reoccur if the Proexp.msc is open on a Win2000 workstation and then saved in the new 2000 version


Troy Funte
Liberty Electronics



----- Original Message -----
From: ams@...
To: Vantage@yahoogroups.com
Sent: Friday, January 18, 2002 8:08 PM
Subject: [Vantage] XP MMC and Progress Explorer Tool



> I have run into a problem with the Progress 9.1C Explorer on the NT 4.0
> Server after running the Progress Explorer on my new XP Pro Client. It
> seems like the MMC on XP modifies the file and makes it incompatible with
> the NT 4.0 (MMC 1.1) tools.
>
> Does anybody know a workaround so I can manage the databases on my server
> once again? What files do I need to recover from backup?
>
> Thanks
>
> Mercer Sisson

Yahoo! Groups Sponsor
ADVERTISEMENT




Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and Crystal Reports and other 'goodies', please goto: http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto: http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto: http://groups.yahoo.com/group/vantage/links

Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.



[Non-text portions of this message have been removed]
At 08:08 PM 1/18/2002 -0500, you wrote:
> I have run into a problem with the Progress 9.1C Explorer on the NT 4.0
> Server after running the Progress Explorer on my new XP Pro Client. It
> seems like the MMC on XP modifies the file and makes it incompatible with
> the NT 4.0 (MMC 1.1) tools.

There is a newer version of the MMC (1.2?) that you can download from MS
and run on NT 4 systems -- that might help. If you're running the newer
MMC, either the updated one on NT4 or the standard one with Win2000, you
need to modify the Progress Explorer shortcut and add a command line
switch: /a

Try searching for MMC on the support site, there are a few articles.

-Wayne Cox
Twenty Three -- Information Technology Consulting
wcox@...