10.2.400 New Install Gotcha's

When installing the RL10.2.400 iso and once everything is installed and you select the checkbox to launch the admin and… nothing happens. This is most likely because the server does not have .NET 4.7.2 installed but the Epicor installer never checks for this prerequisite to notify this is required and not installed on the machine.

2 Likes

Doing the UD file download now, but where is the RL file located? This is all I see in the downloads section.

Under Releases

I guess I should look more closely next time

Just Reminding Everyone when you upgrade from a older version to a major version it is best you not just upgrade your AppServer but DELETE it then Add a New AppServer with the same old settings. Its recommended in the Upgrade Guide but kind of not so clearly stated.

  1. Remove AppServer from Admin Console
  2. Via IIS Management, Remove the Application then the App Pool
  3. Delete your IIS Directory Example C:\inetpub\E10_Demo
  4. Delete the LocalClient from Example C:\Epicor\LocalClients\E10_Demo

Then a new AppServer will deploy without a problem, I’ve seen people struggle or upgrade current AppServer only not to receive updated web.config files, lurking CSG IEx Assemblies are left etc…

11 Likes

Here is a great example with Screenshots WHY…

UPGRADE vs REBUILD APP SERVER


Our ERP Admin Upgraded our Test Environment, while he Rebuild our DEV Environment look at the difference both 10.2.300.13

Test since its an older web.config exhibits all kinds of API Issues. Token, fix that, then its something else etc…
2019-05-16_1400

While DEV Works fine.

5 Likes

After moving to 10.2.400.2, I could not get a second appserver to connect at all in Admin Console or Client. Turns out that if the manager password is anything other than ‘manager’, Epicor thinks it is expired on the second appserver (even though it worked fine on the first). If you get this error and do not want have a manager password of ‘manager’:

Application Log Error:

Message authentication failed.
Service: net.tcp://server/appserver/Ice/BO/UserFile.svc
Action: Ice:BO:UserFile/UserFileSvcContract/IsPasswordExpired
ClientIdentity: DOMAIN\login; …
ActivityId:
FaultException: Invalid username or password.

  1. Restore the second appserver database (test to pilot, live to test, etc)
  2. Attempt to connect to the new appserver in admin console
  3. After it errors right-click the new appserver -> properties -> change password to ‘manager’
  4. After it errors again right-click the new appserver -> properties -> change password back to the password from your source database, and it will connect immediately.

You’ll need to follow those steps every time you restore one database to another if you don’t want ‘manager’ as the password.

Just stumbled across this error when logging in enabling the Active Home Page checkbox.
image

Problem PRB0212804 is identified in Epicare

https://epicorcs.service-now.com/epiccare/?id=form&sys_id=44d391bfdb51334026d3a9a5ca96194c&table=problem&view=csp

This occurred after performing an upgrade from 10.1.600.25 to 10.2.400.3

2 Likes

Just had a bit more of double take. There is a DMT user checkbox in user account security. Help says this works in conjunction with DMT license flag in licensing. Checked our license, and it is unchecked. Thought I was going to have to request a new license…added DMT and the .lic file to my client for 10.2.400 and it ran…Whew! At least I can keep going while I wait for the licence key to arrive.

Edit:
And I can’t read the help…
User Account Maintenance-Options Fields

Note: Security Managers and Global Security Managers have access to the DMT functionality even if this option is not selected.

1 Like

@Hally, I requested a new licence for .400 to include DMT and they said to continue to use the old one. Can you let us know if Epicor gives you an updated license with DMT included?

2 Likes

Still waiting on a new license key…Will let you know @amurdock.

Cheers

Not sure if this is just a standard thing or not but I kept getting prompted to select a certificate when clicking on the Data discovery button.

image

image

This was happening when using Chrome as the default browser. Turns out it was the SSL settings on the site. It needed to have the client certificates set to ignore.
image

I tried setting this at the virtual directory level, but it made no difference, but as soon as I set it at the site level it stopped the message.

I still have users being prompted for their domain username and password, but at least that is a prompt they can understand. (We are using SSO).

This is great stuff… I’ll be starting my upgrade to 10.2.400.xx next week from 10.1.500! God I hate the FDA…

2 Likes

Lot Tracking?

Got the key. DMT check boxes work the way they should now.

The eyes are everywhere you’re on a list now… at least that’s what @Chris_Conn tells me

2 Likes

If you arent on at least 2 government watchlists, you should be ashamed of yourself!

2 Likes