10.2.600.5 - Not able to open any menu items using Active Homepage after switching plant or company unless you reopen ERP

I installed 10.2.600.5 this morning and noticed quickly that I am not able to open any menu items from either browse or menu structure after switching to another company or plant. Only way to open the menu in the company or plant you switched to is to close ERP and open it again.

I had my co-worker double check me just to be sure he got the same result :face_with_monocle:

1 Like

Is it both the shell and active home page that have this behavior?

Active Homepage only.

Search work as expected in Shell.

Kristine, we had some odd things happen in the Active/Kinetic home page that Epicor support told us to Maximize the home page window and that seems to have addressed it.

We are still implementing, but on 10.2.600.5 cloud. The Widgets were grayed out for us unless we maximized the kinetic home page.

Something to try…


I have a multi-tennant on 10.2.600.5 where all new users created have no menu search and cannot use Kinetic at all - (unless they have favorites from the Shell saved).

I have a support ticket open on that one.


1 Like

@bboes Thanks! I’ll look into the widgets to see if I run into similar issues.

Per prod development this issue is currently in the process of being resolved on KTNC-5568.

@DaveOlender - we are on prem and I was able to add a new user, log in using Kinetic Home Page. I am not able to use the search bar or open any menu items for this user unless using the Shell menu. Note: The 2nd time I log in with the new user account. Menu and search works correctly.

Ms. Kristine: Thank you - I don’t know that i tried the second login “trick”.

I have one user that I KNOW did not work. I even gave Epicor support access to login to that user (in Pilot of course) and they confirmed that they could not get the Kinetics Menu search to work.

I got the same thing for new users i added - however i did not try a second login.

Thanks again - I will give that a try.


1 Like

@bboes - I can’t seem to add any widgets with screen maximied or not in 600.5.

We are getting ready to Go Live with 10.2.600.9 on Labor Day and I just notice the same thing where you cannot view anything under All Menu or search any menus. I did not notice this at first because this is not an issue if you are a security manager.

Also in Shell if you try to switch to tree view in Menu it crashes the application unless you are a security manager.

we went live this weekend and I had to make sure to update the security id on the Main Menu in Menu Maintenance. It changed with the 10.2.600.9 patch for us

I have fixed this issue. The problem was in Menu Maintenance on the Main Menu item “Security Manager Only” was checked and “Allow Access to All Groups/Users” was not checked. These two checkboxes did not seem to matter in 10.1.600 on the Main Menu but now in 10.2.600 this will remove access to all menu items in the Kinetic Home screen and cause issues in Shell. After changing these two checkboxes users who are not security managers now have access to all menu items again.


Thanks Jeff! That solution solved both problems - no menu items in kinetic and also crashing when switching to tree view in standard view Epicor. We are on 10.2.600.11.

Appreciate you sharing this with the group!!


Has anyone else seen the following bug:
Opening Company or Plant specific Favorites freezes the UI, unless the Favorite is removed and rebuilt.