11.2 install hung up at adding certification

We are testing out installing 11.2 on windows 2019 server and sql server 2019, hosted on AWS. We have an app server and database server. We have added the database to database server management and move on to adding the app server, but are having issues getting past adding the certification. We select the certificate that is needed for install, ping the server—all checks out—then click apply and OK. All seems good. But when we right click server and select add application server (or even just Properties = cert not selected any more), we get the error “The IIS Web Server needs to have SSL setup before administering Kinetic application servers…” If we go back to properties of the app server, the certificate is no longer there.

We have tried adding the app server after setting up the certificates in IIS, but that doesn’t change the behavior. Have also tried several suggestions found here (such as editing the bindings, deleting/re-adding the HTTPS binding, adding certs to trusted, etc.), and have spent a couple of hours on calls with Support. They confirmed that all of the prerequisites were done properly, but nothing they have tried either has resulted in the certification sticking.

We also had this same problem trying to install 10.2.700.

Obviously something is wrong with server, or IIS, as I does not work with IIS certs either.
Try to review event log for related errors, maybe switch on SCHANNEL logging to have more of them.

Thanks to @Olga and colleagues, we discovered that in IIS Manager, the “Default” site must be named “Default Web Site” (in case anyone else comes across this same problem and spends a week trying everything else under the sun, except that).


Season 3 Wall GIF by The Simpsons

1 Like

yes, good thing Nathan spot it on the flight :slight_smile: i would never notice it

1 Like