AP ACH Payments

I am attempting to customize the AP ACH Payment for Wells Fargo. However, when I try to generate the output file (before any edits), I get an error in the System Monitor:

Input string was not in the correct format

I assume that the standard file is not the problem, and it is something with my setup, but… what?

While I was customizing AP ACH for Citizens Bank years ago, I remember getting similar messages that were very unhelpful at finding the real problem. I ended up deleting blocks of code (or commenting) until it ran. As I recall, the problem turned out to be that the comments in the code said it was pulling data from one field when the code was in fact pulling another field (that was empty).

What format are you trying to gen to. Not sure why but most banks default to the NACHA format and that is not the default coming from Epicor.

It was the Vendor Setup… Strange that the error was COMPLETELY not helpful.

Also it took a little bit of time and effort with myself and epicor support to get to the bottom on solving this issue. But it works great for us.

Now that the Vendor Setup is correct…
This Wells Fargo branch is asking for a VERY complicated file format. Looks like I’ve got some coding ahead of me…

@Jason_Woods So we are nearly complete with setting up Wells Fargo’s Payment Manager files. They have asked to test a ACH payment with NACHA Standard Entry Class Code of “PPD”, which doesn’t exist as an option in Epicor. We have only been testing using “CCD”.

As of now, we only see three options in Epicor on the Vendor ACH Entry Class Code dropdown. So I’m curious at what stage you are at and/or if you have run into this scenario. As far as we can tell, there is no UI for us to update the combo box with additional codes and typing in “PPD” and trying to save the record throws a BL error.

It’s interesting the Epicor only contains three while Wells Fargo’s documentation(Supplemental ACH Record, Field 5) supports the following:
ARC Accounts receivable entry
BOC Back office conversion
CCD Corporate credit or debit
CCP Corporate credit or debit with one invoice record
CTX Corporate trade exchange
IAT International ACH
PPD Prearranged payment or debit
PPP Prearranged payment or debit with one invoice record
TEL Telephone - initiated entry
WEB Internet - initiated entry

Did Epicor create the Nacha file format or did you need to manipulate the file?

I had to heavily manipulate the file.

Caleb,

Apologies for dredging this up; however, we’re in process of switching banks, thus a slightly different NACHA format.

Except, we’re being asked to submit expense reimbursement as PPD and not CCD. Like you, we only have 3 choices in the drop down. Did you ever find a solution for adding PPD to ‘Entry Class Code:’ on the ACH Payment tab in Supplier Maintenance?

I would offer that you edit the Electronic Interface file that generates the output. That way you can specify the PPD regardless of what Epicor provides.

1 Like

Right now in process of setting up checkmark in Supplier Maintenance to allow us to identify individuals vs. corporations, then use the .cs to generate the appropriate 5, 6 & 8 records for the groups.

Oh boy. It’s been some time since I’ve touched that area. I did a quick look in our system we don’t have anything associated with that code on the supplier side. And I also don’t see a references to that code in the .cs file. So I guess that the short answer is no. :grimacing:

And the scenario of submitting it as PPD doesn’t ring a bell either.

We did make some custom fields on the payment method that we used in the .cs file but they are unrelated to what you are inquiring about.