Approaching UI Limit

I have several computers that give the error approaching UI Limit. It seems to be all sales maybe because of the salesperson workbench. In Properties I added 64 after Epicor to match Windows 10. C:\Epicor\ERP10.1Client\Client\Epicor64.exe /config=E10Prod.sysconfig
This worked for a little while but now the error is back after a couple of days. Any Ideas.
Thank You,

1 Like

It doesn’t have anything to do with the 64 vs 32 bits it has to do with the amount of stuff on the screen. Windows has a limit to the amount of handles it can have (defaults to 10,000) . When epicor gives that message are you saying “YES” to increasing the limit to 18,000?

You can change the registry keys yourself via GPO

1 Like

For the users that are getting the errors, do you know if they are also using memory cache for closed forms? I’ve heard the error you are desribing happens a lot when this option is used a bit too much. This option would be checked in options for a particular form:

If you’re not sure, you should be able to run the memory leak tester just to see which forms are taking memory.
You can get this by modifying the Epicor shortcut to point to target …Epicor.exe /memory
Here’s what a cached form looks like even when it’s “closed”.


Thank You,

Sorry to resurrect an old post, but I have one user that is having this problem. We have increased windows up to 18,000 and still have the issue. The options are all good, with no issues. Any other things I could look for? We are running Windows 10 on her computer.

A couple of questions:

  1. Is this on a shared machine where any other users are running applications?
  2. Are there other applications running on the computer?
  3. Have you tried running Epicor ERP from selective startup mode?

Not a shared machine; they do use adobe and outlook as well, and I have not. What I have done, and I am hoping this fixes it, was set the registry to 30K instead. That seems to help. Had my tech team do that and so far it is working.