Asset Depreciation Calculation Process - Epicor 10


We’ve recently launched Epicor 10 and i’m trying to run our first ever ‘asset depreciation calculation’ process.

However, the process is not completing. The error report states the following:

“Error. Starting fiscal period / year cannot be determined for Asset/Register: 1455/MAIN”

Where are we going wrong - help!

Hi James,

Have you defined FA Calendar & Fiscal Year. You need to define those under FA ---- > Setup---- > Fiscal Calendar

Please let me know this solves the issue.



Hi Joji,

I have, yes. Unfortunately the problem continues to persist.

Hi Joji,

I have, yes. But the problem persists…

All business transacted with Crossflight Limited is subject to the British International Freight Association (BIFA) Standard Trading Conditions, current edition. Copies available on request or via our website at

The following error message is also being reported:

“Depreciation calculation for Asset/Register 14619/MAIN failed with error: The transaction has aborted.”

Did you ever resolve this issue?

I have a client that is getting the same error on version 10.2.400.9

The other odd thing is that if we select a specific Asset in the filter for the Asset Depreciation Calculation it seems to run for all assets and gives this error for many of the assets.

Hi Rick,

It was a problem with how we first set our assets up on day one when we migrated from a different a/cs package. The following advice isolated the issue and recommended a solution that worked:

You have loaded the assets at their current nbv position with an asset life of the remaining number of months to be depreciated over so, for example, asset number 14553 has an opening nbv of 0.97 and an asset life of one month. This has meant that there was no need to ‘backdate’ the Fiscal Calendar to cover the lives of existing assets as part of the system build. All things being equal, the depreciation calculation should have resulted in a charge of 0.97 in month one. However, the issue here is that the ‘placed in service’ date of the asset is 09/04/2015. 2015 is not in your calendar and, even if it was, the depreciation would charge in April 2015. To handle the assets the way you want to, the placed in service and asset addition dates need to be the same - in this case 01/04/2018. Note - 01/04/2018 being the date of migration to Epicor.

The only way to fix this is to take all the assets out and re-input them with the correct dates. Unfortunately, as they are posted, we cannot simply take them out using DMT. We will need to delete them from the tables.

Signature Image.png

1 Like