Auto Login on HandHelds in Epicor 10

Has anybody configured the handheld to auto login in Epicor 10? In Epicor 9 we achieved this by using Intermec HandHeld Scanners connected to our Remote Desktop Server, and Active Directory users were created for each Handheld, like HH01, HH02, etc.

HH01 would login to the RDS server and automatically launch Epicor 9.05.702 and point to it’s own “HH01.config” file, where I could enter an Epicor username and password in the config file.

In Epicor 10, you cannot store the username and password in the config file anymore, it will automatically clear it out. For full Epicor client sessions, you can still tell Epicor to “Save” the password, but I am unable to do that from the HH menu. Any way around it? Otherwise I’m looking at 2 hours of Epicor consulting time to achieve it, according to our CAM.

The way I do it is:
Setup the pass policy to allow save passwords.

Log in once as the user and set preferences to autologin

I’d like to add that you can set your last USER in sysconfig but you have to place that config both on the server and the client:

<LastLoginID value="CP_ACELL_1" />
<LoginDefault value="Last" options="Last|List|Windows|None" />

I made a special sysconfig specifically for autologin on my MES in this way. It may not be the ‘right’ way, but it works.

1 Like

Epicor completely changed the way passwords are stored in the config files from 9 to 10, now they encrypt the password. Chris’ method is the approved method now.


On the Workstation where the HH client resides, remove the /HH from the command line of the shortcut and login using the standard Client Menu.
From that menu, go to Preferences and select the checkbox to store the user credentials.
Exit the client
Edit the Shortcut and add the /HH back to the command line.

Now the Hand Held client will use the stored credentials.

1 Like

Thanks everybody! I think I’ll setup the MES stations with that configuration. That answers that.

We noticed an issue with our handhelds. We have some auto-prints coming out of our handhelds, BPM when we close a pack on the custom packout screen we have.
If we auto-login with one user, and then a different user puts in their Employee ID to login, system monitor will crash and then we can’t send any more prints through that handheld’s session. So we might just skip auto-login on the HH to help prevent that from happening a little. Still more to test before I know for sure. Not sure if that’s an Epicor bug, or an issue since we’re launching our customized version of the HH menu.

Thanks again!