BAQ Report Time Out - Specific User (SSRS)

We have a BAQ Report that ties out to a SSRS Report Style. When one particular user submits this report, the report stays in running tasks and will eventually time out. The issue is that we only see this behavior for this specific user at this time. When we run this BAQ report with the same report style and criteria as another user, the report snaps back in seconds. We have done this from the same PC logged in as different users. This PC hits the same server on the same LAN.


Less than a minute:

In the BAQ under Actions / Execution Settings
Add in “queryTimeOut” and set it to 60,000 which will bump up the Timeout Setting. Default is 30,000 or 30 seconds so 60,000 should double it to 60 seconds. Or adjust it to your liking.

Thanks Patrick…

But we had the same result for this user with the bumped up execution time on the underlying BAQ for this BAQ report.

We have run this report from the same PC logged in as two different users, one who has the issue and other users who do not. The reports (and the underlying BAQ) snap back quick and return the data. We are running this report with fairly concise criteria as well. The data set is not really that big.

Thinking this is user specific, but would like to hone into on what aspect of their profile/logon creates this problem.


System Monitor / Actions / Configuration
Are both set to the same (Normal 30000, Priority 3000, Duration 7000)

I recall seeing many a posts on here about slow BAQ’s for certain users, and they typically turned out to be a security issue because the BAQ included tables that have extra security due to Territories.

Your BAQ is titled “InvSalesReport(invoic…” So I’m guessing it hits those tables that have that territory security.

1 Like

Hi Calvin,

Thanks for the input here… what is the best way to check security on those tables in the BAQ so I can dig a little deeper? To our knowledge we have not setup anything specific, but things may have changed throughout our upgrades over time.

I made the user a security manager for yuks… but same outcome.


We don’t use territories, so all my knowledge is second hand. But from what I’ve heard, this security is built-in to Epicor, and not anything you can control.

It has to do with authorized users assigned to workforce, and territories.

Check out this topic:

Particularly the 2nd and 3rd posts

The underlying BAQ was set to be Cross-Company. When we lifted the flag on the BAQ, the report ran in a timely manner for the user. Fortunately, we do no need this BAQ Report to be Cross-Company for this particular instance.

In a test environment, I added in all the companies for the user in question and left the Cross-Company flag on the BAQ. I thought this might be a good solution, but the slowness remained even with the user assigned to every Company in the test environment.

If I get time (doubtful) I will dig further.

Thanks for all the help.