Barcodes not scanning correctly - RDS server

We are implementing new Windows 10 IoT thin clients. When using our SG20T Intermec barcode scanners to scan Job Number barcodes (Code 39 full ASCII) into the ‘Start Production Job’ window in MES, the job number comes in with a ‘j’ on the end of the string. Typically there would be a line feed command here, and epicor would interpret this as a tab (I think we had to define that translation somewhere in a config file).

This behavior does not happen on our WES7 thin clients. We are running Server 2012R2 for RDS. It also does not happen outside of the Epicor client on the server when connected through the new Thin Client.

Not Sure without seeing an example Barcode. Typically on your Job Number would be merely prefixed and post-fixed with a *


You would not embed any carriage returns or tabs in the barcode. You would configured the HandHelds to send a Tab or CR+LF after the scan.

I actually happen to own a Bluetooh Intermec SG20 and mine works fine.

Maybe you need to Disable or Enable some Postamble settings, or change your USB HID

Perhaps check this out

You are correct, it looks like all of the Postamble processing is happening in the SG20T device, not in the barcode. We are just passing the job number. Changing the Postamble setting from CR+LF to Tab, the barcodes work correctly on the hardware. On the old hardware the barcodes scan correctly, but do not tab out of the field like they do with a CR+LF postamble. We will have to reprogram them every time we change hardware. It’s annoying, but it is definitely better than it not working at all.

Thanks for the information!