Bartender Commander hangs when printing from certain button I created in Epicor. Need Help please!

Weird issue to me.

In Epicor, I created a button to print selected rows from grid. worked fine on anther menu I did this to.
This one seems to lock up Commander until I restart service a couple of times.

The difference with this is: the label printer is connected USB to a PC and is shared. I installed that printer from the share onto the bartender server. Test prints from Bartender itself work fine. It only hangs when coming from Commander. I then hooked same printer up to network and ran test, printed fine. Where it is getting installed really needs to be USB, otherwise I wouldn’t care.

Back to USB configuration, if I switch Commander from Service to Application, it works fine. I would like it to stay service if possible.

Anybody else come across this before?


Anybody ever had this before?

Ours works fine as shared and with a service. We have some issues with the printers staying shared, but it’s not a bartender issue. Probably contact Bartender service and they might have a better answer for you.

When you’re running commander as a service it’s using “nt authority\system” as the user. The printer share might have security settings only allowing authenticated users. Try allowing “everyone” and it may work. Otherwise you may need to add the printer using the “nt authority\system” user.


You are my hero!

The permissions didn’t work but logging in as the account that BarTender was tied to and installing print er there worked like a champ!

I really appreciate you sending me down that path!