i wrote a DD on BPDirective Table, intention was to enter some logs once anybody updates any BPM, it was just a start, but there was some errors and got saved.

now i cannot update any BPM including the above, i cannot update/delete the same.

i tried to disable the BPM from DB directly, still the BPM is working and throws error, then i deleted, still the BPM is working and trows the error. then i deleted the BPM files from C:\inetpub\wwwroot\Epicor_Test2\Server\BPM\Sources\DT\ERP.BpDirective.Triggers

still the BPM is working and throws the error. where all other tables or files i have update/delete to get rid of this BPM.

created a BPM with same name on another test environment and tried to install using solution workbench installation failed with same error.

the below is the error

Server Side Exception

BPM runtime caught an unexpected exception of ‘FaultException’ type.
See more info in the Inner Exception section of Exception Details.

Exception caught in: Epicor.ServiceModel

Error Detail

Description: BPM runtime caught an unexpected exception of ‘FaultException’ type.
See more info in the Inner Exception section of Exception Details.
Program: Epicor.System.dll
Method: ResolveService
Line Number: 94
Column Number: 17
Original Exception Type: FaultException

Client Stack Trace

at Epicor.ServiceModel.Channels.ImplBase1.ShouldRethrowNonRetryableException(Exception ex, DataSet[] dataSets) at Ice.Proxy.BO.BpMethodImpl.Update(BpMethodDataSet ds) at Ice.Adapters.BpMethodAdapter.OnUpdate() at Ice.Lib.Framework.EpiBaseAdapter.Update() at Ice.UI.App.BpTriggerEntry.Transactions.MainTransaction.adapterUpdate() at Ice.Lib.Framework.EpiMultiViewTransaction.Update(IEnumerable1 dataSets)

Inner Exception

Type ‘Ice.Tables.UD11’ is not a service contract

After any of your updates did you stop/restart the application pool? Or recycle?

You can disable all bpms by updating the web config and set customizations disabled.
Then fix your error

hi jose,

thanks for the reply. i have already removed the BPM, i cannot update it.

i recreated the same with same name and it is still throwing the same error after i enabled the customizations.

Whatever’s still affected by the old BPM, it probably referred to it with DirectiveID, not the Name. So you’re not really overwriting it.

Do you have backups? Can you restore a copy from before this directive? If you can’t just replace the whole test environment, you could import the restored problem directive, clear out the contents while it’s default disabled, and then try enabling it.