Bpm security for partplant table

epicor version 9.05.701

TASK: allow only users of a specific security group to modify partplant. Other users can view only but not modify.

PROBLEM: I created a security group called “part only” and then assigned it to a few users in user security. I then wrote a bpm as per screenshot below:
This works and if anybody without that usergroup assigned tries to modify partplant then the error populates HOWEVER, this error also populates in other places of epicor which i wasn’t expecting (job entry being one when you click Get Details)…so i’m thinking the BPM needs tweaking a bit. Can anyone help?

Thank you in advance.

Hi Mark,

How about first checking where the call is coming from first, similar to this below?


Hi Nancy,
not something i’ve tried before and not sure what to apply.

Ok, so if you only want this to happen when the user is in part entry, which I suspect is what you’re looking for, then check that they are coming from there before running the exception. Do it as a 3rd condition. One way to get the assembly name is from within the program, Help / about / system info / software environment, per below.

My main reason for this suggestion is to try and follow along with how you are already heading, with the DD bpm on part entry to limit the privs. It look to be fairly easy fix, if this works IMO.

1 Like

i just tried it and so far so good!
i’ve learnt something new today!..thank you so much :slight_smile:
i’ll keep testing

1 Like