Breaking/Routing Corruption?

Hello all,

Running into an issue that we have not noticed for about a year, but it has come back with a vengeance. When in Report Styles (the modern screen) for our ARForm style, I try to click “Design” to work on the Breaking/Routing of our invoice. However, every time I do so, it freezes up my Epicor and then after about 15 seconds, it closes it altogether. This issue only occurs for our ARForm report style, I have tried it with others.

All of the breaking/routing still works, but I have been asked to add a message to the emails that are going out today and cannot get in there to do so. I have tried looking at it in the Kinetic screen, but cannot find a way to go in and edit. All I see is this screen:

Does anyone have a good resolution for this? Or even a way to prevent it from happening again in the future?

I would check your RDD and disable (un-enable?) any fields you are not using. This is a consistent issue with the ARForm.

1 Like

I’ll have to give that a try. Thanks!

Disabled lots of fields, but still can’t get into the Breaking/Routing part. Had a call yesterday with EpicCare to diagnose the issue, but didn’t get anywhere so it got transferred to the Technical team (where they told me it was only an issue for one style and I would have to reformat). I ended up going in and testing the report styles that were supposedly working. One of them still crashed my Epicor, while the other one threw a relationship error (I wasn’t careful enough when disabling the fields I guess) and then the Breaking/Routing section opened up! I went in to fix the relationship in the Data Definition and when I went back to open up the Breaking/Routing section, it crashed my Epicor again…

So, until this gets fixed by Epicor, I guess you could just “break” the report data definition, fix the email, and then “fix” the data definition again.

I’ll try and remember to update this topic if Epicor deploys a fix for this.