Can't add more items to Kinetic Application Maintenance

When I pull up Kinetic Application Maintenance, I only get these items in the picture below. I also get our company but I cut that out. And that only allows me to block all kinetic usage for the company. Which is not what I want.

I only need to disable Kinetic for the print label window and I cannot seem to disable it.

I have all the security options authorized to my account. Unless I’m missing something.

Also when I try to disable Kinetic for the entire company, I get this error:

What I don’t get is, I’m a security manager.

Global Security Manager is a step higher than Security Manager. The GSM is what Epicor SaaS uses for certain tasks.

@Mark_Wonsil Since we’re using Epicor cloud, how do I get that changed?

It looks like the Epicor adminstration console but I think thats for only on premise installs.

Just curious, why is that?

NVM: Disabling kinetic from menu maintenance - ERP 10 - Epicor User Help Forum (

Epicor SHOULD be helping you with that small print font problem. The best solution is to get that solved. If you have a ticket number, raise that with the Kinetic team or post it here so maybe @Edge can follow up on it for you.

My bad, didn’t see your NVM post. Ticket is CS0002592185. All I really want to do is disable Kinetic for that window. I don’t know why it’s not as simple as they show in videos or help docs.

Seems Kinetic is causing issues but for only the print label screen. We’ve proven it’s Kinetic that is the cause.

When we print labels and it uses the Kinetic UI for the print label window, it prints the label tiny. I know you’re thinking the print settings are off, but we messed with all the settings and nothing changed. Only when we printed previous old labels, Epicor used the old UI and it printed the labels fine. On another machine, they selected to not use Kinetic and the labels print without issue. It’s only when it’s Kinetic the labels don’t print right. Why, I have no clue. And it seems nor does Epicor support either as I have a ticket in with them and there is no resolution… so far.

Problem is, I try to disable kinetic per the user and it won’t let me. I go to options in the print label window and it shows the drop down for UI options, but it’s greyed out and selected to “Users choice” (forget the exact wording.)

So I tried to disabled it from Kinetic Application Maintenance but that doesn’t work as you can see. And I tried menu maintenance as well. All no go.

For me, THIS is the real issue. Labels should print for you and every Epicor customer. Did you create a regular support ticket or did you use the Kinetic Feedback form? I know that people like @Edge and @amelton REALLY want to know what’s wrong with Kinetic forms and get them fixed. Kinetic is the future and they would rather get it right rather than have people disable it. The clock will be start clicking here for classic forms here shortly, so it’s better to fix the Kinetic form ASAP.

I get that. I know it’s the future. It is a regular ticket, set to High priority, which I sent in last week. Maybe I need to escalate the case.

In our case, it’s mission critical and we just hired on a new guy in our warehouse who cannot receive product because of this issue. Which as you can imagine, isn’t great for business. We have another machine/person that can but that kind of defeats the purpose of hiring the additional person on.

Which is why, for now, I just need it to run. What ever it takes. Disabling kinetic seems to be the simplest solution.

I hear you and I understand the urgency. I would HIGHLY recommend using the Kinetic feedback form. Escalate the ticket and provide that number to the Kinetic Team. They will be the ones who would know how to disable the form and at the same time be able to fix the problem.

1 Like

Alright, I’ll go that route. Thanks for the help!

Are you using the edge agent?

Negative. Using the normal Epicor 10 installed client

Solution. Epicor sent an update out and I was able to disable “Print Label” window from “Kinetic Application Maintenance”

1 Like