Changing SQL server in Docstar

Does anybody know of the procedure for changing the SQL server for Docstar installations? We are upgrading to SQL Server 2019 in preparation for Kinetic, and moving the databases and updating the config files aren’t working.

Our Docstar server is staying put, just wanted to point to the new SQL server.

@Doug.C There is a SQL server entry in Astria_Host database CompanyInstance table that does not get updated by rerunning the install wizard. I had an issue with my dev instance pointing to the production data that I just got fixed by changing this record. There are also the datalinks that point your E10/11 server that you can change in the UX.

Thanks, that was the issue.

When I switched back the config to use the original SQL Server, it worked, but I got consistent errors in the event log. I think maybe both running the install and updating this record needs to be done.

Over 12 hours with no errors in the event log, I think it’s good. Thanks!

1 Like

I must have missed something because I got a lot of errors when the daily maintenance tried to fire off. I don’t see anyplace where that old server is listed.

@Doug.C Here is the SearchAll script I use. I searched for my SQL server in AAAA0001 and in Astra_Host. I don’t know how the EclipseSyncDB or EclipseSignalRBackplane fit into the picture.

I also found there is a database server on the IDC server called DocstaridcServerDB.

Is your maintenance DocStar or SQL? What are the errors?

SearchAll.sql (2.0 KB)

Thanks!

It returned no results for the old server, and the field you mentioned for the new server.

I’m wondering if it is in a cache somewhere on the server itself. I’ve searched all of the files on the server for the old server name and I only come up with a few places, but they are log files only.

Can you post some of the messages? Are they from sql or ECM

Here (nothing I can find is still pointing to the old server):

Log Name:      Application
Source:        Astria.Server.Web
Date:          7/25/2021 9:12:29 PM
Event ID:      0
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Description:
Sql Error Occurred, Connection Information: DB: AAAA0001, ConnString: data source=<<OLDSERVER>>;initial catalog=Master;integrated security=False;user id=sa;password=*****;min pool size=100;max pool size=1000;multipleactiveresultsets=True;connect timeout=30;application name=Astria.Server.DOCSTAR, Error: 
System.Data.SqlClient.SqlException (0x80131904): Database 'AAAA0001' does not exist. Make sure that the name is entered correctly.
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
   at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
   at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async, Int32 timeout, Boolean asyncWrite)
   at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean& usedCache, Boolean asyncWrite, Boolean inRetry)
   at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
   at Dapper.SqlMapper.ExecuteCommand(IDbConnection cnn, CommandDefinition& command, Action`2 paramReader)
   at Dapper.SqlMapper.ExecuteImpl(IDbConnection cnn, CommandDefinition& command)
   at Dapper.SqlMapper.Execute(IDbConnection cnn, String sql, Object param, IDbTransaction transaction, Nullable`1 commandTimeout, Nullable`1 commandType)
   at Astria.Framework.Core.DapperBase.GetConnection(Boolean hostConnection)
Error Number:911,State:1,Class:16,
ProxyURL: 
Event Xml:

Docstar is working, I’m able to attach documents. So I’m not sure what’s doing this. It’s every minute.

If every minute I would think it is sync db, but I have no idea. I found the same kids of errors on backups failing in my event viewer, but I can’t find the backup job.

Well,

Thanks for your help. You got me working. I’ll submit a ticket tomorrow and see if I can figure out what I missed.

1 week until Kinetic upgrade. I’m feeling better about it now…

1 Like

@gpayne Was this the root of your problem we discussed in Vegas? I didn’t realize there was an entry in the DB that did NOT get altered with re-running the install/setup program.

I submitted a ticket and they said I have to go through Professional Services to get it fixed.

:roll_eyes:

@MikeGross This was the root of the issue, but I also had a few other issues left over from cloning the servers. I got tired of waiting and untangled them myself this weekend, so I could start writing workflows.

1 Like

It seems to be a configuration item in the ASP.NET installation. Looking at the DLL the error is coming from, it looks like it’s getting the server from that config. I’ve looked around at all I know to look at to see a connection string/application setting, but I came up with nothing.

I found some messages like yours from when I was doing maintenance and rebooted the sql server. I saved the service settings on my ECM client. A dialog came up that the settings were written to C:\ProgramData\Eclipse\ApplicationServices.config. I looked at that file and it is encrypted. Maybe resaving all of the ECM settings for Services and any batch imports will clear the issue.

Greg

1 Like

That did it. I wish I could mark both of your items as solutions…

Many, many thanks! I’ve waiting almost a week for Epicor to even get back to me about support or professional services. Thanks for all your help!

@Doug.C Your welcome. Hopefully we can build up some knowledge about ECM here so these kinds of issues get easier to solve.

It makes sense as to why everything was working. The errors were from the client, not the web application. My forehead will heal after a week, but the forehead size hole in the wall will need some time for me to repair…

@Doug.C I get it. I am working on my first workflow and am clueless as to why some of the things work and others fail.