Column not showing in Kinetic grid/personaliztion, is in data view

I have a dashboard that I’m converting from Classic that is not showing two particular columns (OrderDtl.ExtPriceDtl & OrderDtl.Discount) in the grid nor in the “Personalize Columns” panel, but they are in the data view and not hidden. I can see them in the grid model > columns, but they do not show in the grid. I can check the “hidden” box in Grid Model > Columns and then uncheck it to see the columns in Application Studio. However, when I preview the screen they appear in the active card, but as soon as I move off that card to another then the two columns have disappeared from all cards, including the one they were initially showing in.

I’ve tried by converting the old dashboard (making some layout changes to the cards in application studio) and by building it new from scratch. I’ve got six different BAQs in this dashboard that all include these fields and every single one of the grids is having this same exact issue.


Has anyone else experienced this or know what I might be able to do to fix it?

Have you tried deleting those columns from the grid model, saving, then adding them back in?

Do you have DB access?
You could pull the JSON and see if there’s a sticky property. If so, remove it, then push it back into the DB.

That sounds like fun, which table would the customization JSON be in?

Ice. XXXDef

TypeCode = ‘KNTCCustLayer’
Key1 = Layer name
Key2 = Program like Erp.UI.PartEntry
SysCharacter03 is the JSON in App app Studio.
Content is the JSON for the published layer.

1 Like

Thanks Hannah. This is either going to be the best thing since sliced bread or a long dark tunnel of trouble… [Would be nice if there was a column to show the final result of all the adds and replaces etc!]

Deleting and re-adding did not change the behavior. (Was hoping that was a “duh!” moment)

I’m on Public Cloud, so don’t believe that even with the JSON details, I wouldn’t be able to then update them

Found another dashboard that includes these two columns, plus OrderDtl.UnitPrice that this behavior is happening with, too.

I’ve opened a case with support about this, since it does not appear to be related to specific dashboards. Will post their ultimate reply here.

I’m running 2023.2.5 and still have this issue. Did Epicor convert your Case to a Problem?

I actually left that company before the ticket was resolved.

@FObilo Felix, are you able to respond in regard to this issue if EpicCare converted the case that was open on this when I left to a Problem and/or provided any resolution to it?