Copy Report Style

Hello! good evening

I have a problem when I want to copy a report style.
When I copy the POForm report style that is from the system,
When copying it and issuing it, if the purchase order has releases, the report multiplies the total quantity by the number of releases.

Does anyone know why this happens?

Are you clicking “Sync Datasets”? If so, don’t.

Yes, i´m clicking “Sync Datasets”

But if i don’t click Sync Dataset, can i run report?

When you copy the report, it keeps the old RDD and also copies the original SSRS RDL file. THis means you can run the copy without doing anything more than simply “Copy Report Style”.

“Sync Datasets” should really only be used for BAQ Reports. Otherwise the button should say “Break report completely and make me start over”.

1 Like

Ok, I understand, what I have to do is copy the style and run it without clicking Sync Dataset.

I’m going to try that option and return my comments to you.

Thank you!



It works very well!

thank you very much!

Wow! I was having a similar problem with the OpenPO report, hope this fixes it, Good to know. Thanks for the info.

OMG! It solved my problem. I have spent countless hours on this. I was creating a data directive to automatically send the report. I needed to add contacts table. I would always synch and the lines on the PO report would duplicate based on the number of contacts. It now works! Thanks so much! Much Appreciated! And thanks Carlos for posting!



A question,
if I remove excluded from a field, how can I see it in the list of fields in the Report Builder?

Because i remove the exclusion but i can’t see the label in the report builder.

In Report Builder, you must modify the SQL for the affected dataset(s).

I understand that the data sources option must be the one you select in the Report Style Maintenance form, in the Data Definition option, or am I wrong?

Why is a different data source coming out?

Has something similar happened to you?

No. It would be the POHeader dataset that needs to be modified.