Copying data from dashboard in Win11 is extremely inefficient. Use Ditto

Anyone ever run into anything like this before? Thinking of a big hammer, reinstall the client approach unless others have suggestions?

1 Like

There is a hidden folder on your main drive called ProgramData. (in Windows Explorer, click View, then check the box for Hidden Items). Inside that folder is a folder called Epicor. Clear out the contents of that folder. You should then uncheck Hidden Items, close Explorer and try running Epicor again.

I think I figured it out, so posting for others that may run into this issue…

I found the problem was specific to a dashboard, that is Epicor would crash only for this one dashboard but not others. I tested on another PC and it worked but was super super slow(other dashboards were fast). I then experienced an out of memory error and couldn’t open any Epicor screens.

I noticed this particular dashboard returned a large amount of data(6.6k rows), and the problem only happened if I didn’t filter the data(fewer rows = less work for the client) and if I used copy selection(must have more work to do than copy all).

I suspect:

1.) Epicor’s out of memory handling in 10.2.400 is not so great(not gracefully catching the error).
2.) It’s possible to design a dashboard(to many rows) that the client/dashboard can’t handle, one must use filtering.

Are there any other settings or best practices for dashboard design when a large amount of data is returned to avoid these types of problems?

No luck still the same problem, but really appreciate that suggestion!

Looks like the theory was correct, Epicor runs out of RAM(32 bit application can only access 4GB) and crashes(Open task manager copy data and watch RAM consumption climb to about 4GB and then watch Epicor crash and the process disappear). I’ve seen it handle this gracefully and ungracefully. Simple fix, filter the data so fewer rows are returned…

There is Kinetic64.exe too if you really need to get beyond

1 Like

@josecgomez thanks! I have a really odd data point hoping you might be able to help with.

I’ve got two computers(Windows 11) that behave as I describe(takes over a minute to copy 5 rows from a dashboard with over 6.5k rows and requires well over 4 GB of RAM). I have two other computers(Windows 10) and a server(Windows Server) I can perform the same operation on and the copy is instantaneous(same data, same dashboard) and I don’t see any additional RAM consumption. Both computers are running the 32 bit client, same dashboard, same rows copied, tested at the same time(the data in the dashboard didn’t change), and same user. The only difference I can find is the fast computers are windows 10/windows server and the slow ones are windows 11.

How can we troubleshoot a problem like this?


I don’t have a W10 machine I can currently test on to give you an answer there.

I can add that on W11 I have the same dashboard copying issues. However, if I use a clipboard manager application like Ditto on W11 then it copies correctly without skyrocketing memory usage and locking my Epicor client.

It’s possible something is goofed up in the W11 clipboard. The only thing I saw in Microsoft’s support page is that W11 supports “Automatically sync text that I copy” while it’s not listed for 10. Not sure if it’s the issue at all, it’s just what I found.

1 Like

You sir are correct! Thanks, the issue does appear to be with Windows 11 clipboard as I have confirmed once I installed Ditto I no longer need 10GB of RAM and have to wait for over a minute to copy 5 rows out of a dashboard with 6.5k rows :slight_smile: