Creating a Help Desk Case using a Data Directive

I’m very new to EPICOR and have a question regarding creating a HD Case via Data Directive method. We’ve been able to create an HD Case entry when a Nonconformance is triggered from MES. I actually have successfully created my Task Set and workflow of tasks and milestones.

Just to give a little background of what this project is supposed to do. We wanting to use the workflow functionality to handle items when the Nonconformance quantity is entered for jobs. This workflow will be required for these items that need to be reviewed. So, we know we’re using the CRM workflow functionality differently. This workflow will determine if items are ok, need to be reworked, or scrapped. This maybe a little more information that is needed, but this is the reason for this project.

When manually creating the HD Case via Case Entry window, the workflow is fine. The issue is when the Data Directive executes and creates the HD Case based on the nonconformance quantity, the Workflow Group is populated correctly, but the Current Milestone is not populating.

How can I populate the ‘Current Milestone’ value for the Case Entry when this record is automatically created? I don’t see where this field is available in the HDCase object.

I hope this wasn’t confusing. This is my 1st project in EPICOR. Looking forward to hearing any responses.

Welcome aboard @Kflora.

At this point I can’t provide too much feedback, but I do recall running into something like this back in another life working in E9. I’ll try to put my thinking cap on to see if I can remember.

Before going down the rabbit hole of BPMs etc. What happens when you try to just create a case manually, no MES etc. Just plain old Open Case Entry and add a case? Are you 100% sure that the Tasks are configured correctly (i.e. First Milestone is checked on correct task?)

Hello! and thank you for reading my topic. I’m pretty sure it works correctly. That’s how I was testing my project by creating the Case outside of MES. The workflow works as expected and the First Milestone checkbox is checked. The Next Milestone is defined and everything … no issues that way.

Maybe this might help concerning this ‘Current Milestone’ field. When the Case is create via Data Directive, I mentioned that the Current Milestone value is not populated. When opening the Field Help for that field, the system has no DB Field listed. If there’s not a DB Field associated with it … where is it coming from when the case is created manually outside of MES? I really think that’s what I’m missing.

Thank you again for responding.

I believe I’m closer and if I’m able to solve this I’ll post the solution here so someone else can benefit from my lose of hair. Not to mentioned I’m learning more of EPICOR everyday. It’s just a frustrating way to learn it.

When Help Desk Case is created, the ERP.Task and ERP.TaskCnt are not being created. I’m getting a message indicating that they don’t contain a definition for ‘RowMod’. That looks to be system generated and didn’t think I needed to set that value for these 2 records. Do I even need to create the ERP.Task and ERP.TaskCnt records that are to be associated to the Help Desk Case ? I think I’m trying to do more than I need to.

I need the TaskSet to be associated to the Help Desk case that is being created so when the Case is opened, the tasks are there and can be edited/completed. I just need a little direction of exactly what needs to be created to do this … There’s just not much out there, that I’m aware of, for doing what I need to.

ANY suggestions would be greatly appreciated.

Have you compared a trace of manual creation to your bpm creation?
I think if you set the WFGroupID and the TaskSetID and update then Epicor will take over and create the task tree.


Thank you for looking at my post. Please bear with me as I’m really new to EPICOR.

My Help Desk case entry is being created when the Nonconformance entry is saved. Within that Help Desk Case, I am including the TaskSet ID, the Workflow Group value, the Current Workflow Stage ID, the Active Task ID, the Current Milestone (sequence) value, the Current Milestone Description value, the Task Set ID Task Set Description, and the Stage ID. Adding all of this to the HD Case, the system still doesn’t know the Current Open Milestone. There are no Task or TaskCnt entries.

Attempting to duplicate what is in a manual process produces by creating the Task and TaskCnt entries via Data Directives haven’t worked either. Being that I am so new to EPICOR, I’m not sure what the system will, or should, do for me.

So, I believe I’ve done what you’re asking and the process isn’t doing what I need it to do. I find it a little frustrating that the Table Setup Mapping for the HelpDesk.HDCase shows 223 fields, however viewing the HDCase table via query only has 85 fields. I’m used to building my own queries directly instead of using a tool like Data Directive Maintenance.

To answer you question about the trace. I’ve done it once and it basically told me what I already know which is it doesn’t have a value for the Current Open Milestone … which is plainly defined in my milestones and task values in my TaskSet.

Thank you for taking the time and giving me your suggestion. I’m all ears if you have anything else that you happen to think of.

@Kflora I do more searching than posting usually here and most of the time can find a solution.
If you have not used the BL Tester to model your case creation then that would be a way to know you are calling the methods correctly and getting the result you want.
The first link from @MikeGross below has a complete Case creation bpm in it if you want to review one that works and model yours after it.
The second link is on EpicCare about Epicor resources. I find a lot of information searching the KB there.
I assume you already have the ICE and Customization guides for your version. If not those are on the EpicWeb site.


Posting with Case creation BPM

Epicor resources

1 Like

Couple of things that may help - Data Directives have a different ‘scope’ when executing and some things are simply not available to them so they cannot do all of the functions that a MD can do. I can tell that I started at DD and moved to MD because of that, but I’m hard pressed to remember which thing didn’t work.

Also, the RowMod thing is tricky. If you look at the MD @gpayne referenced, you’ll see at least two places where I ‘create’ the rowmod in order to make it work. And I do recall that the Task piece was the worst of it all, but it’s been so long…

The MD/DD editor is nice that you can copy/paste between directives, so I would try yours as a MD and trigger it on a special value in one not-so-used field just for testing purposes. If you find the intended action works at the MD (but not the DD) then you’ll have to punt :slight_smile: