Cust Shipments not accepting specific pack #s on new shipment

I’m trying to import shipments via DMT, and the system won’t accept my pack numbers, It’s assigning the next available number sequentially. The same thing happens when I create a new shipment in the program. I key in my pack number, and when I click the save icon it re-populates with the next available pack number. When I blow the data in manually with SQL, the system doesn’t recognize the documents. Is there a setting somewhere that I am unaware of, to stop ignoring my data? The documentation states that the sequential number is assigned only if the packnum is 0 upon save. Any ideas appreciated, thanks.

I am going to ignore the bit about putting data in via SQL (refer to the thousands of posts here about why you should never ever in a billion years ever never ever ever never do that, support gets angry, I get angry, you risk breaking your system and causing corrupt data, orphan records, murdered unicorns, the universe develops a black hole… Just don’t do it. OK?)

I guess I didn’t do a good job ignoring it after all :smile:
You can’t assign your own arbitrary PackNum just leave it at zero when importing with DMT and the system will gladly give you the next one. If you are importing from another system, then add a custom field to the ShipHead table and store your custom pack num there.

1 Like

They shouldn’t state that you can if it isn’t an option. Particularly when migrating from an earlier version of their software.

Well you can provide your PackNum but that will just update the existing one. If you do the migration via the upgrade process it works fine.

We are moving from Vantage 8 to E10, and my organization has evolved and morphed significantly since V8 was implemented, so the 8-9-10 migration upgrade path is not a viable option.

Makes sense, are you trying to import prior packs for historical purposes? Or are these open PackNums?
If they are there for historical purposes then you are in trouble here since there is no way to insert your own packnums. You could do what I suggested and use a Custom UD field.

Your other option is make sure they import in order and set your Next Pack Num to be the pack Num you want to generate next. If you don’t have your records jumping all over the place that could work.
Basically if you want to import pack num 1,2,3,4 set your Next Pack num to be 1 in your company config, then import in DMT in that order and it should match.

Except that at this point, we have six-digit pack numbers so it would take some effort to “run up” the counter in E10.

You can set the starting pack num I believe in your configuration to whatever number you’d like

You can use a data directive to reset the packnum after Epicor has assigned, but before it is written. Put your packnum in a ud or unused field in the dmt file and then set packnum to the ud on the added row.


That’s an interesting workaround. I will give it a shot, thanks.