Custom combo box on a custom dataview -- Almost nearly, but not quite hardly


I had a reusable warehouse bin combobox working and filtering from a warehouse code field in the UD02 record. But it was unusably slow (tons of locations), and I have 48 of them on this form.

So, I created a custom dataview and filled it with a BAQ. That part works.

Then I looked at the settings that the reusable warehouse bin combobox fills and made some guesses. It almost works. In fact, it worked once after I published the layer, but stopped working after I made some changes and tried again.

I have a temporary grid that shows the contents of the dataview, and it gets what I’m looking for. But the combobox shows only the first bin location code (not description), and it gives me only the first record in the dataview.

Here are some screen shots of what I did:


It doesn’t seem to matter what I put in the Drop Down Style field:

I suspect I missed an entry somewhere. Anyone done this?



Here was the difference: