Dashboard 1000 row limitation

Has anyone found a workaround for the 1000 row limitation in dashboard grids. We have several dashboards that would normally return more than 1000 rows that unfortunately will not work as expected in Kinetic 2024.1.

2 Likes

Not a workaround, but can the data on these dashboards not be broken into more-consumable chunks? or summarized into groups?
My mentor in a previous role had me think about Why I was pulling large sets of data:
When will we need to see item #1000 (or higher)? or even item #500?
Is it really a dashboard if there is more data than can be quickly processed by a single person?

It might be worth it to break up a large query into more-specific queries that return less data, faster … and avoid fighting with the limits of the system.

My two-cents, unsolicited.

5 Likes

Hi! Not sure if this is a solution, but in BAQ designer, I was recently shown how to overcome the limit (because I often don’t have time to make something a dashboard, I just want to export all results to Excel).

In BAQ designer, go to the Run Query tab and click on overflow menu>execution settings.
image

Then set it up like this:
image

Again, sorry if this doesn’t resolve your issue. But this tip was so helpful for me and wish I’d known how to do that months ago!

7 Likes

That only applies in the baq designer, but it is a good tip for those that need it. :heart:

6 Likes

As @tpogue and @mbayley say.

"Use virtualization and server paging in the grid to limit the number of
rows rendered in the browser. Best for when there are more than
500-1000 results (depends on number of columns) "

Here is the link to their dashboards session at Insights.

3 Likes

It almost sounds like your dashboard is executing the BAQ once to return the first page of results, then not executing again.

In your panel card gird, are you using the Provider Model? More results should load as you scroll.

image

2 Likes