Dashboard filters not working if field is updatable

I have a dashboard with filters in one panel, a grid in another panel, and updatable fields in a another. If the use refreshes the dashboard while the updatable panel has the focus, none of the filters from the Search Panel are applied. Anybody have any ideas on how to fix this? This is very unintuitive. In this case, it takes 20+ minutes to load the dashboard when refreshing because it’s pulling all employees and not filtering.

Oh yes! This is a problem we’re working with Epicor to fix.

The work around:

  1. Open your dashboard and make your changes.
  2. Open Menu Maintenence
  3. In Menu Maintenance, your dashboard in view, remove the .dll by deleting the contents in the field Dashboard:
  4. Save the current Menu Maintenance
  5. Restart your Epicor instance
  6. Re-Open Menu Maintenance and add back in the .dll for your dashboard
  7. Restart Epicor again then try your dashboard

It’s a pain, but it works for now.

Hi Jonathan, thanks for the reply but I’m still getting the same behavior.

Maybe I’m not understanding step 1, do you mean the deployed version or the dashboard maintenance? I tried both, refreshing from an updatable field still doesn’t use the filters.


Try creating a copy of Dashboard and deploying that with your changes. You can then make changes to the original and re-deploy the dashboard with the originally made Dashboard. I sometimes run into problems as well when the dashboard won’t show the changes even after clearing the .dll.

Jonathan I don’t think we’re having the same problem. I don’t have any problems getting my changes to show.

My issue is that the filters applied to the BAQ results don’t work when refreshing the dashboard from an a textbox that is marked as updatable.

The one question I have is, is your BAQ is marked updatable as well? Meaning are you using an updatable BAQ? If not then the dashboard is just a query or lookup.

You want your Dashboard to update information, then the BAQ has to be updatable.