DataLink for Other Instances

I attempted to contact support for assistance in pointing our data link to production, but I was flat out told that professional services have made it to where only they are able to do this. Sounds about right with Epicor’s seriously lacking support.

Anyways, I managed to identify why only Pilot was working when setting the datalink source. It turns out that the following URL is enabled for pilot, but not for the other environments. This is where I’m stuck, not sure how to expose this so that I can connect to production.

The URL ECM is attempting to use: https://HOST/ENVIRONMENT/Ice/Lib/SessionMod.svc

Any insight would be appreciated, thanks!

edit: to clarify, I mean the AP Automation data link.

Generally, you control all the datalinks for external sources that you want to use, using the Datalink editor.

The integration piece that Epicor delivers is controlled by you as well, for the datalinks they delivered, using the screen below. Unless there is something else going on in your environment, this should be where you can change the Appserver connection (the change from Pilot to Prod for example)

Hi Mike,

Thanks for the quick reply! I don’t think I explained my issue very well.

When I change the “App Path” on my V1 integration (exactly as shown above) to anything other than our pilot instance, it fails saying there is no connection. I identified the cause to be that URL I mentioned previously not being accessible. I can physically navigate to it on pilot and not on prod.


I see, ok…Can you show me the Appserver section of the Admin Console, and a shot of the Appserver Config screen for the “Epicor10” appserver?

I’m thinking that you do not have the Epicor10 appserver configured to turn on REST and the Token Authentication. Plus, the Docstar connection requires a change to the Bindings inside the web.config file. This is sort of complicated stuff, but it’s covered in the documentation. We created a separate Appserver just for Docstar as you can see from my screenshot.

I asked about documentation for this from support and got nothing. Going back to look, I see some helpful docs but nothing mentions a web configuration change. This is probably is the issue, however. REST and Token Authentication are configured.

<add scheme="https" binding="basicHttpBinding" bindingConfiguration="BasicHttp" />

I used a diff tool to find this as one of the only differences. Might be what I am looking for.

Yes I believe it is. Here is a doc that spells it out.
E10 Integration.pdf (567.9 KB)

Yup! I made that change and it worked. Docs say that is the solution as well.

Appreciate the discussion, hopefully this can help more people. In this case, I was jumping into an existing 1-year project and support was less than helpful to get us on track without paying more despite being a simple solution with docs.

Glad to help. Go to Epicweb, Docstar docs - there is a bunch of stuff in the ‘unversioned’ section, plus the other ‘versions’ stuff. While some of it is old, it’s a treasure trove of data for us do-it-yourself-ers.

Strangely enough, I can’t find that exact doc in my list. Oh well.

( I may have gotten this one from ‘someone’ on the inside… )

1 Like