Debugging using Jose Customization tools

Hello when I try to debug using the visual studio addon it is giving me this error:

    See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentNullException: Value cannot be null.
Parameter name: path
   at System.IO.Directory.GetFiles(String path, String searchPattern)
   at CommonCode.EpicorLauncher.RunDnSpy(CommandLineParams o) in C:\Users\jose\source\repos\CustomizationEditor\CommonCode\EpicorLauncher.cs:line 449
   at CustomizationEditor.NonModalWokIt.btnDebug_Click(Object sender, EventArgs e) in C:\Users\jose\source\repos\CustomizationEditor\CustomizationEditor_10.2.400\NonModalWokIt.cs:line 99
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

This uses DNSpy do you have that installed? I recommend you try the built in debugging in regular customization mine uses reflection and it is better (if you are able to) to use the Built In Customization Debugger that Epicor has.
Write the code using visual studio, sync it and run it then debug it using the native tools.

If you can’t do that for some reason then mine will work but it requires an external application called DNSpy to be setup and configured correctly.

Yes I have DNSpy here:

I tried debugging but it says something about needing a executable file when doing from visual studio

Run your customization normally from Epicor and click the Debug in Visual Studio CheckBOx bottom right of the Customization Selection Screen.
(From Epicor not from Visual Studio)

Oh I can’t debug from Epicor.

Ah yeah that’s a bummer, I’ll take a look at the debug stuff I haven’t looked at this in a while.

1 Like

Thank you! :raised_hands: I am using latest update for visual studio 2019

I get exactly the same this issue, can you help me to solve this?

I think you need install Visual studio professional, check box “Debug in Visual Studio” will be enabled.

I’m using VS 2019 Community Edition and it works fine,maybe some plugin is missing or it is not installed correctly.

According to EpicCare the issue is they are not detecting the VS install and you need to check this article for where the registry key should be. I am also using 2019 Community on several machines.