Deployed dashboard appears like dashboard maintenance

Hi all,

My team and I recently finished developing a nice dashboard for querying and updating certain values. Everything has been going well until we tried to deploy it as a menu item. As soon as we deployed and assigned a menu slot to it, upon opening it, some weird events occur (which were NOT present in the “Test Application” option):

The following image is how the Dashboard is supposed to look when deployed (“Test Application” before deploying), and the one after is how it appears as a menu item (after deploying):

As you can see, for some reason, the “General” tab from Dashboard Maintenance is retained. We’re unsure of why this is happening after it’s deployed, or how to remove it. In addition, we have some custom code with the dashboard that does not get run after being deployed.

Anyone have any thoughts or solutions for this?

Did you pick dashboard assembly, or dashboard runtime in the menu maintenance?

Hey Brandon,
I chose Dashboard Runtime. However, I also tried Dashboard Assembly, and that seemed to achieve the same result.

So when you deploy a dashboard in the dashboard menu, that is creating the dll (the assembly) of the dashboard. That get’s stored on the server and pull to the client if you have a menu item created with an assembly dashboard.

If you don’t need to customize the dashboard (or run updateable), you don’t need to deploy it, you can simply add the menu item as run-time and the dashboard will work for the end user fine. You also will have fewer problems with caching. If it’s large the assembly-dashboard will probably load a little quicker, and for updateable it needs to be as assembly.

That being said, if you used the assembly dashboard for the menu item, did you close an re-open epicor? It won’t pick up the change to the menu structure until you do that.


Concur, Menus only refresh when you login.

Thank you both. That did the trick! At first, I did a simple “Change User” (top left icon) and thought that would accomplish it. Turns out that it required a full Epicor shutdown and re-log. Much appreciated for your help @Banderson, and for adding your knowledge @hkeric.wci!

I think we’re loosing Group By, Filter… functionalities with a the RunTime Version.

You shouldn’t be.

We just went from 10.1.600 to 10.2.500 and we have noticed several dashboards which now “wake up” in the “General” tab instead of the dashboard itself.

Is this a known E10.2.XXX problem?